BT and WiFi issues plus some app issues following recent update on 7p

salbaum

Member
Jan 5, 2022
7
0
0
Visit site
Sorry for the long title. I want people to know what they're in for before reading the rest! I'll list the issues, then I'll list what I did to attempt a fix.

After the recent update to the OS, the following happens.

Plugging the phone into the car/android auto sometimes resets the phone

Spotify fails to advance to the next song in a shuffle or playlist whether connected by bluetooth to a portable speaker or android auto. It's one-song-at-a-time. Even hitting the button to play the next song fails. The play button fails. I have to request a song all over again.

Tidal is no longer operable via voice command or at all on android auto.

I sometimes have to reset my phone to connect to anything by bluetooth. "First try" connections rarely occur anymore.

Spotify can not "cast" to anything over wifi at home anymore. It sees the device, attempts connecting, disconnects... nothing

The phone no longer can screen cast to my LG OLED. I used to watch Tidal videos that way. No more. However, in the youtube app I can cast to my old Roku just fine.

My Weather Underground app doesn't appear correctly in my notification screen. It's blank.

Here's what I tried:

I went into app permissions and gave the apps all the permissions, though they already had adequate permissions

I restarted the phone (on purpose this time)

I posted here in this forum (and one other, but...)

So, I'm at a loss. The variety of problems makes me think I shouldn't try to address them on an app-by-app basis, plus it was night-and-day following the update. I may poke around a spotify forum or two, a tidal forum...but since both apps are affected in sort if similar ways, I think the problem is bigger...

Thanks. It was a problem free phone before this and since I play a LOT of music I'm thinking of going to the AT&T store to remedy the issue at this point...
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,967
5,280
113
Visit site
You're talking about the March security update, right? Are you also up to date with Google Play system updates? You can check in Settings>Security & Privacy>Updates.

Also make sure you're up to date with Android System Webview. But also keep in mind that sometimes, updates to Android System Webview can cause odd things to happen (especially if you're on the Beta), so one thing you could try is to uninstall updates to ASW (or, if you're on the Beta, leave the Beta program).

Definitely send Google feedback about all of this from within the system settings menu.
 

salbaum

Member
Jan 5, 2022
7
0
0
Visit site
Thanks. I resolved the Spotify portion of the issue by clearing app cache, then un-installing and re-installing the app. Something about that March update seems to have messed with my cache. I haven't driven enough yet to know if the occasional resets from connecting the phone will continue and I still have to test voice commands with Tidal.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,967
5,280
113
Visit site
This update has ruined the battery life on my 7 Pro. It's disgusting to see that Google still can't get monthly updates right.

I haven't seen any hit to my battery life since the update. Have you checked your battery stats to see if any particular app or service is using an unusual amount of battery?
 

Members online

Forum statistics

Threads
944,531
Messages
6,923,244
Members
3,159,608
Latest member
nasrulawal026