Cannot access usb

Nick Oliver1

New member
Sep 3, 2018
2
0
0
Visit site
I cannot access my phone with computer via USB.
Pixel 2 xl running Android 9.
My wifes phone will connect but she opted out of beta and is still running 8.1

The phone will charge with the USB but will not
Give the drop downmenu to select file transfer

Searching USB in settings shows me the screen to adjust these settings but all options are greyed out and cannot be changed.

I have tried enabling USB debugging etc but nothing seems to change.

I would love to revert back to Oreo 8.1 but without being able to connect USB to computer that doesn't seem possible
 

Rukbat

Retired Moderator
Feb 12, 2012
44,528
28
0
Visit site
Make sure you're connecting to a USB 2.0 or 3.1 port, or using a 2.0 or 3.1 cable. Pixel 2s and USB 3.0 don't work well together.

If you still can't get it to work, back up everything and call customer support. It's still under warranty.
 

GSDer

Well-known member
Jan 30, 2011
8,469
15
0
Visit site
Have you tried a different cable?
If that doesn't make a difference, get a clean toothbrush and/or compressed air (be sure the phone is turned completely off) and clean out the USB port.
 

crazed_z06

Well-known member
Mar 26, 2011
71
4
0
Visit site
I cannot access my phone with computer via USB.
Pixel 2 xl running Android 9.
My wifes phone will connect but she opted out of beta and is still running 8.1

The phone will charge with the USB but will not
Give the drop downmenu to select file transfer

Searching USB in settings shows me the screen to adjust these settings but all options are greyed out and cannot be changed.

I have tried enabling USB debugging etc but nothing seems to change.

I would love to revert back to Oreo 8.1 but without being able to connect USB to computer that doesn't seem possible


Dont know if you're having the same problem, but I just got my Pixel 2 XL replaced under warranty for a similar issue. I recently bought a car with Android Auto and it requires a wired data USB connection. When I connected it to the car, it would only charge 80% of the time instead of starting android auto. I know it wasnt an issue with the car because my work GS7 didnt have an issue and carplay worked on my gf's iphone. Then I tried plugging into a computer and got the same behavior. Sometimes computer would see the USB data connection. Most times it would just charge. I tried all kinds of different cables and everything you can imagine.

Finally broke down and called Verizon and they sent me out a refurb that is working flawlessly. So there was definitely something messed up with the port on my old phone.