Question Car Head Unit Stuck on Boot Logo

RubberToe

New member
Oct 17, 2023
2
0
1
Visit site
I have a bit of an issue with an Android Head Unit. It doesn't seem to have an actual brand name; this is how it was described:

Android 11 Car Stereo GPS DAB CarPlay Radio Mercedes Benz E/CLS/G W211 W219 W463

I have it just over a year and it has now got stuck on the boot up logo. The unit does not have any physical buttons, just a few touch sensitive ones that only work when Android has loaded. There is a reset hole on the front accessible using a paper clip etc. I have tried it many times and it just restarts the unit. I'm told the unit needs an update and the supplier (hstsmarteknavi) gave me a link to a zip file to download with some simple instructions, shown below:

update software link:https://we.tl/t-qvYtxZfk8J

Upgrade steps

1) zip after downloading (only unzip once)
2) Copy the file to the U disk
3) Connect the U disk while the power is on
4) The machine will automatically upgrade
5) update process video :https://we.tl/t-9074zMmd9C

The software link works but the video link has expired. Anyhow, I downloaded the file, unzipped it and placed the 2 files it contained onto the top directory of a newly formatted USB drive (Fat 32). I connected it as directed and the led lit up - but no change to the Android Unit. I've tried different USB drives and even different cables. The supplier seemed to be happy to answer questions initially but has now stopped.

I've attached a pic of the only potential clue to what the unit might be. I've also found a head unit from another supplier that looks identical - see Link to other supplier.

Does anyone recognise this unit or can anyone help me resolve the problem?
 

Attachments

  • Identity.jpg
    Identity.jpg
    581.4 KB · Views: 2

Trending Posts

Forum statistics

Threads
941,642
Messages
6,909,917
Members
3,158,008
Latest member
lonewolfnz