Cast Button Disappears After A Few Seconds in Most Apps


New member
Oct 2, 2012
Visit site
Hey there, I'm having a strange issue, and I can't find anyone else having this problem.

I got my Chromecast yesterday and when I was trying to test it out in Play Music, the Cast button kept disappearing after a few seconds. Initially I thought the Chromecast was to blame, but then I tried with my (rooted) kindle and older Android phone, both of which do not have the same issue. This leads me to believe it's a problem with the Chromecast app working with my phone. I tried reinstalling it, and still having the same issue.

To reiterate, with HBO Go, Hulu Plus, and Play Music, when I start the app, I have maybe 5 seconds with the casting button in the app before it completely disappears. If i'm quick enough to start a movie or something, it WILL cast, but I cannot figure out why the button disappears.

The phone I'm using is a Huawei Premia 4g. This is very frustrating to me because it has the newest version of Android of all my devices, the others are too old to have the version of Hulu Plus with Casting.

Any advice? I'm really stumped here, and don't want to buy a new phone just to justify a $35 Chromecast...


Well-known member
Sep 14, 2010
Visit site
It's not the Chromecast app since that app plays no role in casting whatsoever. You don't even have to have that app on your phone. However, since you do have it on your phone, you can use it to verify that your phone is on the same network as the CC and can communicate with it.

It sounds like there is some issue with your phone and wifi. If the cast icon is disappearing from all your casting apps, it seems that the phone is either using mobile data instead of the wifi connection or that the wifi connection has switched to a different network.

So do some testing with those two things. Manually shut off all mobile data and verify that the apps still stream to the phone without interruption over wifi. Also verify the wifi connection is not getting disconnected momentarily and/or is not switching to a different SSID/network.

Check your wifi settings (including any advanced settings) on your phone for any settings that may be interfering. I don't own that phone so I don't know if there is anything in particular to check. Also, check any other apps, like task killers, power/battery savers, security apps, etc that have settings that may interfere.

If you can't find the problem, you may have to do a factory reset of your phone, but do some troubleshooting first.