Chromecast lagging my Macbook pro big time

jd914

Banned
Feb 3, 2010
798
36
0
Visit site
Anytime I use Chromecast to view live broadcast like CNN, my computer bogs down considerably and on top of that audio and video come in delayed and when someone talks it sounds like I'm viewing a translated foreign movie. The delay/sync in audio and video is that bad. Also, video comes in choppy and not smooth at all. Do I need to upgrade my computers memory or is this an issue that Google needs to address? TIA
 

lostchild

Well-known member
Nov 15, 2012
499
0
0
Visit site
I have 10.8.4 ...2012 model 13 inch running stock everything. NEVER had lag issues until I hooked up Chromecast. I am using Chrome browser.

It is probably a 2nd gen i5 with 4Gb RAM and Intel HD graphics. It is probably not going to cast 720p (which is the default resolution) smoothly. Try changing in option to 480p under google cast extension. I have a i7 and 8Gb RAM and AMD discrete graphics and I still haven't been able to cast 720p smoothly. :(
 

Farish

Well-known member
Apr 29, 2013
1,289
0
0
Visit site
I have 10.8.4 ...2012 model 13 inch running stock everything. NEVER had lag issues until I hooked up Chromecast. I am using Chrome browser.

That should be fine, how is the distance from the router to the chromecast?

It is probably a 2nd gen i5 with 4Gb RAM and Intel HD graphics. It is probably not going to cast 720p (which is the default resolution) smoothly. Try changing in option to 480p under google cast extension. I have a i7 and 8Gb RAM and AMD discrete graphics and I still haven't been able to cast 720p smoothly. :(


I thought that was your HP Laptop and your wife's macbook work fine?
 

techisking

Member
Aug 17, 2013
8
0
0
Visit site
It is probably a 2nd gen i5 with 4Gb RAM and Intel HD graphics. It is probably not going to cast 720p (which is the default resolution) smoothly. Try changing in option to 480p under google cast extension. I have a i7 and 8Gb RAM and AMD discrete graphics and I still haven't been able to cast 720p smoothly. :(

Possibly, could also be a network problem or bandwith issue.
 

jd914

Banned
Feb 3, 2010
798
36
0
Visit site
It is probably a 2nd gen i5 with 4Gb RAM and Intel HD graphics. It is probably not going to cast 720p (which is the default resolution) smoothly. Try changing in option to 480p under google cast extension. I have a i7 and 8Gb RAM and AMD discrete graphics and I still haven't been able to cast 720p smoothly. :(

This fixed the issue! The resolution is not the best but no lag on my Macbook Pro. It's now casting in real time and no delay in picture and sound. Just wish I could do the full Extreme (720p high bitrate).
 

Farish

Well-known member
Apr 29, 2013
1,289
0
0
Visit site
This fixed the issue! The resolution is not the best but no lag on my Macbook Pro. It's now casting in real time and no delay in picture and sound. Just wish I could do the full Extreme (720p high bitrate).

So are you doing 720p normal or 480p?

Sent from my SAMSUNG-SGH-I467 using AC Forums mobile app
 

Farish

Well-known member
Apr 29, 2013
1,289
0
0
Visit site
I have 10.8.4 ...2012 model 13 inch running stock everything. NEVER had lag issues until I hooked up Chromecast. I am using Chrome browser.

480p I doubt I can stream any higher than this.

Sent from my GT-I9505G using Tapatalk 4

This boggles my mind, Until it broke I had 720p on my Macbook and it was a Core2duo 2.13ghz model with 6gbs of ram with SSD. My rmbp 13 inch is running this at 720p and all it has is an intel HD 4000.

The only machine that would make sense based on those higher specs is my iMac with is a i5 quad core, 32gb ram, and AMD 6750. A SSD shouldn't make a difference should it?

- - - Updated - - -

I have 10.8.4 ...2012 model 13 inch running stock everything. NEVER had lag issues until I hooked up Chromecast. I am using Chrome browser.

480p I doubt I can stream any higher than this.

Sent from my GT-I9505G using Tapatalk 4

This boggles my mind, Until it broke I had 720p on my Macbook and it was a Core2duo 2.13ghz model with 6gbs of ram with SSD. My rmbp 13 inch is running this at 720p and all it has is an intel HD 4000.

The only machine that would make sense based on those higher specs is my iMac with is a i5 quad core, 32gb ram, and AMD 6750. A SSD shouldn't make a difference should it?
 

anon(847090)

Well-known member
Jul 8, 2012
6,655
31
0
Visit site
This is absolutely not the problem. I'm thinking because my Macbook only runs on 4GB of RAM therefore it's not doing a good job at casting.

there was an article by Phil or Jerry about disabling hardware acceleration which made macbook pro work properly with chromecast.

worth a try
 

lostchild

Well-known member
Nov 15, 2012
499
0
0
Visit site
I thought that was your HP Laptop and your wife's macbook work fine?

Well, it was my niece's macbook pro 15 retina display 2013 with i7 cpu and 8Gb RAM and discrete graphics. It costs as much as all the other 3 laptops in the house combine LOL. She uses it for picture and video processing. Yeah THAT macbook pro cast chrome tab perfectly. ;)
 

kunalotron

New member
Aug 27, 2013
3
0
0
Visit site
Hi, i am having the same issue on my 13inch Macbook pro.
Terrible lag while casting. How did you fix the problem, Please help or I will have to return my ChromeCast. :mad:
 

kunalotron

New member
Aug 27, 2013
3
0
0
Visit site
This fixed the issue! The resolution is not the best but no lag on my Macbook Pro. It's now casting in real time and no delay in picture and sound. Just wish I could do the full Extreme (720p high bitrate).

Hi, i am having the same issue on my 13inch Macbook pro.
Terrible lag while casting. How did you fix the problem, Please help or I will have to return my ChromeCast.