Contact Birthdays Not Showing In Calendar

Rizy7

Well-known member
Dec 6, 2012
638
0
0
Visit site
Does anyone know how I can get my contacts birthdays to show in my calendar?
When I go into calendar and click on calendars to be displayed, the contacts birthdays calendar is checked but does not appear in my calendar.
The only way I am able to show the contacts birthdays is if I go to calendar and calendar storage in apps and clear the data
 

N4Newbie

Trusted Member
Nov 15, 2012
5,006
1
36
Visit site
I would love to know how to fix this as well.

Open Calendar and tap menu -> Calendars to display. At the bottom of the screen, tap "Calendars to sync" button. For each calendar (if you have more than one), check the box next to "Contact's birthdays and events".

Works for me.
 

teletraan1

Well-known member
Mar 26, 2012
91
1
0
Visit site
Open Calendar and tap menu -> Calendars to display. At the bottom of the screen, tap "Calendars to sync" button. For each calendar (if you have more than one), check the box next to "Contact's birthdays and events".

Works for me.

Awesome! Couldn't find this earlier. Much appreciated!
 

N4Newbie

Trusted Member
Nov 15, 2012
5,006
1
36
Visit site
I don't know what else to offer. My guess is that your People list (where, presumably, you have stored the birthdays) is not linked to the same account as your Calendar.
 

Seabass7857

Active member
Nov 21, 2012
30
0
0
Visit site
Have you tried verifying all the info from your calendar and contacts from a PC? I always had issues setting it up from phone, but once i jumped on my computer and setup everything, it started syncing automatically.
 

Rizy7

Well-known member
Dec 6, 2012
638
0
0
Visit site
Have you tried verifying all the info from your calendar and contacts from a PC? I always had issues setting it up from phone, but once i jumped on my computer and setup everything, it started syncing automatically.

Yep.. Everything is synced and fine when I check it on the computer. Just refuses to update on my actual calendar.. Unless my calendar app is interfering somehow?
 

JZ002

New member
Apr 29, 2013
1
0
0
Visit site
Hi, I have the same issue.

Tried every approach above (sync in phone, set up in computer Google account) still my calendar in phone not sync the birthday. Pulling my hair at the moment...

(LG Nexus 4)
 

Rizy7

Well-known member
Dec 6, 2012
638
0
0
Visit site
Make sure both contacts and calendar are synced when you go into settings, accounts and Google Account.

Then go to settings, all apps, find calendar and calendar storage. Clear the data on both and then everything should be working fine.
 

Kamin

Well-known member
Jul 1, 2010
149
2
0
Visit site
None of the above worked for me. But the following is what did.

1) On a PC, login to the Google calendar account you have synced on your device.
2) Settings> Calendars> Browse interesting calendars> More
3) Click "Subscribe" to Contacts' birthdays and events
4) On your device, open Calendar app
5) Menu> Calendars to display> Calendars to sync> Contacts' birthdays and events.

^^ That's the process that worked for me.
 

francis lecoq

New member
Apr 30, 2013
1
0
0
Visit site
And it worked for me, thanks ! I learned how to use my google account calendar !

But we can improve the tuto :D for those who wants events facebook but not birthday !!!

1) On a PC, login to the Google calendar account you have synced on your device.
2) Settings> Calendars> Browse interesting calendars> More
3) Click "Subscribe" to Contacts' birthdays and events Click on Add by URL
4) Go on facebook
1 > In Facebook, go to your EVENTS page.
2 >At the top of that page click EXPORT EVENTS
3 > You'll get a pop up window with a URL, copy it. (example : 'webcal://www.facebook.com/ical/u.php?...')
5) Go back to google calendar and put the URL
6) Synchronise your phone with Google (settings in your phone)
6) On your device, open Calendar app
5) Settings > Calendars > Tick Facebook Event in Google Account

Done !!! You don't anymore facebook birthday !!
 

Nativ Weiss

New member
Jun 19, 2013
1
0
0
Visit site
Ok, I had the same problems.

Already tried everything mentioned above, but nothing helped.
In the end I simply "removed" the google calendar from my phone, then re-installed it, applied updates, and magically the birthday appeared :)
 

Guillermo Yow

New member
Aug 12, 2013
2
0
0
Visit site
This was happening to me also, I looked in what calendars were visible and I had "My Calendar" unchecked. Once I checked this box all of my "Contact" birthdays showed up.

So unless all of the birthdays are stored in your Google calendar and synced to your phone's calendar you will have to have "My Calendar" sync to get these to show.

"Contacts' birthdays" at the bottom of the menu was greyed out until I checked the box next to "My Calendar", then it was available to put a check in the box.

Hope this helps.
 

AppieB

New member
Aug 26, 2013
1
0
0
Visit site
My problem with the calendar is that it does not show my contact's birthdays, but the anniversary I also added to my contact. How to can I fix this?
 

Fastism

New member
Sep 23, 2013
1
0
0
Visit site
If u tried many ways but all dont solve the problem, please try this...
- The fastest way is sign in to your Google Acc => Gmail => Contacts
- In each Group, select all contacts and choose to add them to "My contacts" by checking on Group tab
- Now, pick up ur phone n go to System settings\Accounts\Google, uncheck n recheck People details, Contacts n Calendar to re-sync them
- Go to Calendar app n choose Calendars to sync n Calendars to display
That's all! U can see ur contacts's birthday showed? ^^
 

Taz Man

New member
Nov 18, 2013
3
0
0
Visit site
ok guys, after doing a LOT of search and research and after following ALL your indications and instructions, I performed this:
I tried to search manually for a contact that I knew I had imported his birthday on (in my calendar - menu button --> search IN the calendar not in contacts)
the entry was there, it was just there TWICE!
I realized I had duplicate conflicting entries!
I decided to delete the contact entirely and recreate it to see what happens
before recreating the contact I searched again in my calendar with the name of the contact and the birthday was still there
re-creating the contact did NOT resolve my problem.
I figured out that it might either be the Google Calendar Sync Cache or the actual calendar cache (S Planner for Samsung)
Unfortunately, I didn't find a way deleting the cache of the Google Calendar Sync and I'm still trying to find a way and a solution.
I know for fact that removing google account and re-inserting it, will solve this (already tried it) BUT
ALL images I have on contacts will be lost! (at least the actual resolution and size)
ALL connected apps I have with my google account will be lost
My 2-step verification account will create me too many problems
not to mention all other problems I will be facing during the re-insertion of my account.
I will continue again tonight trying to figure out what exactly is going on but my first impression is the wrong insertion of the contacts in my google account when first imported from my very old device (even if this is very remote). I'll keep you posted of my findings
 
Last edited:

Trending Posts

Forum statistics

Threads
943,872
Messages
6,920,397
Members
3,159,268
Latest member
reflavius