"Couldn't add widget" error viewing Recent Apps cards

techhelper95

New member
Feb 3, 2015
1
0
0
Visit site
You have to make the device go into Safe Mode and then Restart.
1. Press and Hold Power Off Button so it restarts in Safe Mode.
2. Once it Restarts in Safe Mode. Restart the Phone normally again.
You're Done! :)
 

N4Newbie

Trusted Member
Nov 15, 2012
5,006
1
36
Visit site
You have to make the device go into Safe Mode and then Restart.
1. Press and Hold Power Off Button so it restarts in Safe Mode.
2. Once it Restarts in Safe Mode. Restart the Phone normally again.
You're Done! :)

Tried that; the problem persists.

I don't use the recent apps button and, in fact, had forgotten all about this bug.
 

Javier P

Ambassador
Feb 21, 2014
19,480
4
0
Visit site
These are the fixes that worked for some people.

Boot in safe mode.

Clear cache and data of Google app and reboot the phone.

Uninstall updates of Google app and reboot. Update Google app and reboot.

Activate Google Now launcher and go back to your personal launcher.

Good luck.
 

N4Newbie

Trusted Member
Nov 15, 2012
5,006
1
36
Visit site
These are the fixes that worked for some people.

Boot in safe mode.

Clear cache and data of Google app and reboot the phone.

Uninstall updates of Google app and reboot. Update Google app and reboot.

Activate Google Now launcher and go back to your personal launcher.

Good luck.

Thanks, but no thanks. :)

I never use the recent apps button anyway. And, even if I did, I would rather live with "Couldn't add widget" than do all of the above.
 

TwiztidMonkey

New member
Mar 15, 2016
2
0
0
Visit site
I know this thread is somewhat old but, I just wanted to confirm that this actually worked for me. I've been trying to figure this problem out for days now but, it's finally fixed thanks to this thread. This problem occurred when I disabled the Google App from my device. I didn't notice the problem had started until, I had enabled the Google App again.

Those of you who are dealing with the same problem, please follow the instructions listed above on booting your Android device in "Safe Mode". Please be advised that it won't actually fix this issue unless, you physically open your recent tabs while operating your device in "Safe Mode". The first time I had tried this method it did not work for me because, I didn't open my recent tabs to check it while my device was in "Safe Mode". When I did it a second time, I opened my recent tabs and saw it reappear which seemed to fix the issue.

Anyways I'd like to say thank you to, N4Newbie for bringing this to the forums attention. I've tried fixing this problem for the last few days but, couldn't figure out why this was happening? After getting so frustrated over this, I finally decided to do some research on it and, well...here I am lol! Well the good news is that, this problem has lead me into creating an account here and now I'm a member...whoop! whoop! 😎

Now I can scroll between different tabs again without seeing an annoying message about, not being able to add the Google search widget to my recent tabs menu. Last time this problem had (occurred) happened to me, I had to perform an entire factory reset on my tablet because, I didn't know or did I have any other solution at the time. Well if there's one thing I know for sure it's, you sure do learn something new everyday, that's for sure...lol! I'm just happy to know that I didn't have to do another factory reset...phew!

All I know for a fact is this. The next time I'm having any issues or have any concerns, I know what website I'll be returning back to. Thanks again to N4Newbie and to anyone else who helped, to put the word out regarding to resolving this issue. Everyone who supplied this thread/topic with such accurate and vital information, you all are awesome.Thank you very much everyone...cheers!

Regards,
-TwiztidMonkey
 

Javier P

Ambassador
Feb 21, 2014
19,480
4
0
Visit site
Welcome to the forums! Thank you for joining and posting such a detailed feedback. It will be very helpful for other people with the same problem. 👍
 

TwiztidMonkey

New member
Mar 15, 2016
2
0
0
Visit site
Hey Javier,

Thanks for the warm welcome! I'm glad to be here and involved with all you awesome people, here in the Android community. Since this amazing thread has helped me, the least I could do was give back by sharing my thoughts and experience. I decided to add my own two cents to the topic and hopefully my information will help someone else down the road.

I'd like to show my appreciation one last time, by saying thank you to everyone who had helped me! I really do appreciate all the vital and helpful information by all means. Thank you all again and may God bless you all. 😇

Regards,
-TwiztidMonkey
 

patraachaar

New member
Oct 3, 2016
1
0
0
Visit site
For my phone (moto g2, android 5.0.1) with same error, its the google search app which worked. I reinstalled google search app and post installation, the "can't add widget" vanished.
(I was unable to restart phone in safe mode somehow - so that is ruled out here)