Delay in E-mail Notifications

js10

Well-known member
Aug 8, 2018
144
1
18
Visit site
I have a MotoG6 that, when I first got it (a little over a year ago), I'm pretty sure gave me the e-mail notification sound the moment I received a new e-mail. Now, however, after several software updates that may or may not have anything to do with this, this has become very problematic. Sometimes I will get the sound, but something like 10 or 15 minutes after the e-mail is received. Sometimes I'll get it only after I "activate" (as in do something to bring it out of the black screen) the phone. Neither of these is good enough! For the work I'm in, I need to be notified of e-mails as soon as they come in. To me, it's not much different from the phone not ringing when someone calls or not receiving a text notification when someone texts. Also, by the way, sometimes I WILL get the e-mail notification sound when a new e-mail has NOT come in, which makes it even stranger.

Does anyone know why this might be happening? I did see a thread in Google's own gmail support forum that other people are experiencing this, so it might just be a general software issue that has nothing to do with my phone. But if there is anything that CAN be done, I would certainly love to know about this because, again, for me at least, this is pretty bad. Thank you.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,976
5,286
113
Visit site
Any power-saving modes turned on? I assume you're using the stock Email app -- try turning off Battery Optimization for it in the system settings.
 

js10

Well-known member
Aug 8, 2018
144
1
18
Visit site
Hi. First of all, apologies for the multiple posts but I was actually getting an error message when I posted them. I hate it when I have technical problems when trying to ask a question about technical problems!

Anyway, no, my phone's "Battery Saver" turns on when the phone is down to 15% but not before then. So I don't believe that's the issue. Thanks.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,185
6,736
113
Visit site
Hi. First of all, apologies for the multiple posts but I was actually getting an error message when I posted them. I hate it when I have technical problems when trying to ask a question about technical problems!

Anyway, no, my phone's "Battery Saver" turns on when the phone is down to 15% but not before then. So I don't believe that's the issue. Thanks.
Hi welcome! No worries I cleaned the other duplicate .

Is the gmail app in optimized battery save when you long press and tap info then tap battery?
 

js10

Well-known member
Aug 8, 2018
144
1
18
Visit site
Okay, here's what happens. I get to a screen with "Battery optimization" as one of the items on the list, and then it says "battery optimizing use" in gray below it. When I tap on that, though, it says "Not optimized" in the green bar. And then a long list of options below that.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,185
6,736
113
Visit site
Okay, here's what happens. I get to a screen with "Battery optimization" as one of the items on the list, and then it says "battery optimizing use" in gray below it. When I tap on that, though, it says "Not optimized" in the green bar. And then a long list of options below that.
Should look like my screenshotScreenshot_20200124-142244_Settings.jpeg
 

js10

Well-known member
Aug 8, 2018
144
1
18
Visit site
Hmm. The format is certainly different. Basically, first I get to the App info screen, then have to tap on Battery, Then I get that screen I told you about with Background restriction and then Battery optimization. AFTER I tap on Battery optimization, I get to that other screen (it takes a few seconds to load for some reason) that says "Not optimized" in white letters in a green bar with a drop-down arrow to the right.

By the way, the Android version I am running is 9.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,185
6,736
113
Visit site
Hmm. The format is certainly different. Basically, first I get to the App info screen, then have to tap on Battery, Then I get that screen I told you about with Background restriction and then Battery optimization. AFTER I tap on Battery optimization, I get to that other screen (it takes a few seconds to load for some reason) that says "Not optimized" in white letters in a green bar with a drop-down arrow to the right.

By the way, the Android version I am running is 9.
Can you post a screenshot of yours ? Android 9 or Android 10 not much different in these app info areas
 

js10

Well-known member
Aug 8, 2018
144
1
18
Visit site
Here they are: both of the screens I've been describing to you. (note: in reverse order for some reason)

Screenshot_20200124-151448.jpgScreenshot_20200124-151424.jpg
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
And stop letting the battery drop down to 15%. Lithium batteries are not deep-discharge batteries. The ideal recharge point is 50%, but letting it drop to 45% won't shorten the life much, If it gets down to 40%, charge it or turn it off. The battery doesn't care how badly you need the phone, it only cares that you let it drop below 40%. (Regularly dropping a lithium battery to 15% could totally ruin it in a few months.)
 

js10

Well-known member
Aug 8, 2018
144
1
18
Visit site
Sorry, caught up in other things. That and I also stopped getting e-mail notifications about responses to this thread, so I wasn't even aware! Anyway, the problem is that when I tap on "battery optimization" in the second image, I just get what you see in the first image (remember, it attached them out of order for some reason). So, as you can see, there doesn't seem to be an option to turn anything off there.

Also, I never said that I routinely let the battery power drop to 15%. Just that it's set to turn on the battery optimization WHEN it does happen. That's their pre-set setting, not mine. That said, I should still probably be more careful about that.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,185
6,736
113
Visit site
Sorry, caught up in other things. That and I also stopped getting e-mail notifications about responses to this thread, so I wasn't even aware! Anyway, the problem is that when I tap on "battery optimization" in the second image, I just get what you see in the first image (remember, it attached them out of order for some reason). So, as you can see, there doesn't seem to be an option to turn anything off there.

Also, I never said that I routinely let the battery power drop to 15%. Just that it's set to turn on the battery optimization WHEN it does happen. That's their pre-set setting, not mine. That said, I should still probably be more careful about that.
On the top where it says not optimized tap the symbol to the right "v " then choose all and scroll down to gmail app and email.make sure it not toggled to optimized, as you see in your screenshot it's being optimized
 

js10

Well-known member
Aug 8, 2018
144
1
18
Visit site
Okay, got it. Yes, it WAS set to optimized and now it is not. It did warn me that this would drain the battery faster, but that's okay if it results in my getting notification of incoming e-mails immediately -- that's way more important. I hope this works! Thank you!
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,185
6,736
113
Visit site
Okay, got it. Yes, it WAS set to optimized and now it is not. It did warn me that this would drain the battery faster, but that's okay if it results in my getting notification of incoming e-mails immediately -- that's way more important. I hope this works! Thank you!
Perfect , it should let me know . Your welcome!
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
It will drain the battery faster if you have it set to check for emails every<whatever number of minutes>. If you have that set to off, it gets emails as the server gets them, and doesn't use any battery power polling the server. (So that's a still faster way of getting them.)
 

js10

Well-known member
Aug 8, 2018
144
1
18
Visit site
No, unfortunately no difference. For example, I just received a notification sound about 15 minutes after the e-mail was received. So, I don't think the battery thing is the issue. What Rukbat said was interesting, though -- if I have it set to check for emails every whatever minutes. I didn't even know that was a setting. Maybe THAT'S the problem. Where is this setting located, and how do I change it to immediate? Again, I would like e-mail to be treated no differently from a phone call or text message.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,185
6,736
113
Visit site
No, unfortunately no difference. For example, I just received a notification sound about 15 minutes after the e-mail was received. So, I don't think the battery thing is the issue. What Rukbat said was interesting, though -- if I have it set to check for emails every whatever minutes. I didn't even know that was a setting. Maybe THAT'S the problem. Where is this setting located, and how do I change it to immediate? Again, I would like e-mail to be treated no differently from a phone call or text message.
Inside the app when you open under setting , push notifications
 

Forum statistics

Threads
944,554
Messages
6,923,356
Members
3,159,621
Latest member
wadeharper