Do not cover top or disable screen touch message for huawaei mobiles


New member
Sep 12, 2018
Visit site
From last few months, I was continuously facing this issue with my Huawie P Smart Mobile that every time, I power on screen it restricts my entry by message that Disable screen touch as shown below.


I tried various option to get rid of this screen lock option but all in vain. Infact most of the people even Huawei team gave different unsatisfactory options. In most of the Huawei mobile this can be disabled by using below option

Go to setting - Smart Assistance and at bottom of it you will find disable screen touch option. Just disable this and your problems will be solved.
However for P smart ( FIG-LA1) models, this option is not available at all which added to my frustration. :mad::mad::mad:

Finally after many endeavors,I found its smart solution as
Just go to google app and download

Setting Database Editor App.

Open app and go to T section ( T Alphabet field) and select "Touch Disbale mode". Most probably its value is 1, make it 0. This will solve this Disable screen Touch or do not cover screen issue for most of the Huawei mobiles.

Hope this would be useful for many users.