Droid 4 not recognizing wifi network

wth1

New member
May 23, 2012
2
0
0
Visit site
The wifi on my Droid 4 seems to be working fine . . . except when I'm at home. When it comes to work, being in Starbuck's, wherever else, there are no wifi issues I've identified so far. But It only intermittently connects to my home wifi network. Most of the time it has my home network listed as "Not in range. . . Remembered." This is true even when the phone is sitting on top of the wifi router. When the phone does decide to recognize my home network, it will also disconnect seemingly randomly (i.e. even in the middle of browsing, not necessarily only after the phone went to sleep).

I've made sure the wifi is set to never sleep. I've tried turning wifi off and back on. I've tried switching into and back out of airplane mode. I've tried rebooting the whole phone. None of these reliably cause the phone to link into the home network. Using "scan" under wifi settings doesn't help either.

I have several other devices at home including a laptop, a wifi enabled printer, my wife's iPod touch and my old Palm Pixi -- none of these have any problems automatically connecting into my home wifi network.

Also, the droid does recognize a number of my neighbors' wifi networks very poor signals while telling me that my own network is not in range.

Any suggestions at this point?
 

wth1

New member
May 23, 2012
2
0
0
Visit site

Deanna Forgette

New member
Apr 6, 2014
1
0
0
Visit site
ok.... my Motorola android 4 was working with my wifi home connection just 48 hours ago. was working just fine when I went to bed. when I woke up the next morning my droid phone, ipod, and iphone was registering the wifi. I don't even get the wifi icon at the top to show its connected. I have done everything I can think of from restarting the router, resetting my phone, turning airplane mode on/off, turning wifi on/off and reentering the password for the wifi. my laptop and another one of our iphones are still connected. my phone just tells me that the wifi is saved and secured. it shows that I've got bars but the actual icon that usually appears at the top of my screen for wifi will not show and won't connect me. I don't know what else to do.... anyone got any other ideas??? please help!!! i'm hoping it will just fix itself. it does connect when i'm not at home with other wifi locations. just stopped connecting at home all of a sudden.
 

delrey1900

Well-known member
Mar 22, 2010
751
0
0
Visit site
My old D4 had this issue too. Drove me nuts. I believe it started when it received ICS 4.0. I ended up trying out WiFi Fixer . This helped me when I absolutely had to connect to wifi. Despite that app, it was still a pain. FYI, my Moto X does not have this problem. Hope this helps.
 

Trending Posts

Forum statistics

Threads
946,056
Messages
6,926,190
Members
3,160,058
Latest member
skylarktg