"e" and "3" keys on keyboard not working in portrait

LondonJohn

Member
Feb 11, 2015
14
0
0
Visit site
Hi,

I have a problem with my Nexus 4, now out of warranty, running 5.0.1

The "e" and "3" keys have stopped working in portrait. Touching the e just types a w or an r (two letters on either side), However, The "e" and "3" keys work OK in landscape.

I'm not aware of anything that happened to cause this problem, it just started a few weeks ago.

Swipe letters works fine in landscape, but in portrait there's no swipe line over the letter "e" when I swipe across the row - line appears right up to edge of r and w but then there's a gap over the e. This is the same in all keyboards tested.

There's no problems with that part of the screen, I can touch OK and screen works fine when not using keyboard.

Tried safe mode, still doesn't work

Tried 4 different keyboard apps, still doesn't work

Tried Resetting App Preferences, still doesn't work

Phone hasn't been dropped or damaged, and everything else works fine.

I'm really out of ideas - can anyone help? :)

Thanks.

J.
 

LondonJohn

Member
Feb 11, 2015
14
0
0
Visit site
Thanks for your suggestion, but Screen Touch Test works fine.

It's not an issue with the screen, as i can touch the same location fine when keyboard is not showing.

It's an issue specific to that key on any keyboard in portrait mode.

Any ideas anyone? :)

J.
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
That's a weird problem! I remember having some problems in the beginning with words like "see" and such, where the keyboard changed the e for a w. But after a few tries managed to include them in the prediction algorithm.

Have you tried setting a different row for the numbers? Keyboards like SwiftKey can do that. See if that makes a difference when swiping.
 

LondonJohn

Member
Feb 11, 2015
14
0
0
Visit site
Thanks.

I changed to SwiftKey and placed the number keys on the right side of the keyboard, instead of top row, and the 3 key worked fine.

I added a row of numbers to top of Smart Keyboard Pro and the 3 DIDN'T work in Portrait but worked fine in Landscape.

So, it seems to be an issue with e and 3 (when I hold e down) AND 3 (when numbers appear on their own row).

Really weird and very annoying!
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
Very weird! So no harm asking stupid questions :) Have you tried swiping with your other hand?

I'll let you know if I find something about that. Post if you find a fix. Good luck.
 

belodion

Co-Ambassador Team Lead
Moderator
Jun 10, 2014
39,238
135
63
Visit site
Have you tried a Cache Partition wipe? It's the sort of fix you just know in advance probably won't work, but maybe worth a try. :)

Posted via the Android Central App
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
Another one. Select SwiftKey and change the layout to "compact". You can do this longpressing the "123" key. This way you're going to know if the problem is in the screen or some glitch with the software.

Not easy to write this way :)
 

Attachments

  • 1423838425253.jpg
    1423838425253.jpg
    59.7 KB · Views: 8

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
If the problem is gone long press on the arrow. This will change the position of the keyboard to the right. Test how many keys don't work this way.
 

Attachments

  • 1423838639576.jpg
    1423838639576.jpg
    51.3 KB · Views: 8

LondonJohn

Member
Feb 11, 2015
14
0
0
Visit site
Another one. Select SwiftKey and change the layout to "compact". You can do this longpressing the "123" key. This way you're going to know if the problem is in the screen or some glitch with the software.

Not easy to write this way :)

Thanks again. :)

Interesting ... the "e" key doesn't work on SwiftKey Full or SwiftKey Thumb but does work on Compact - progress! Does that give any clues? The position of the "e" key in SwiftKey Full and SwiftKey Thumb is different, and as I can touch screen OK normally in those positions when not using the keyboard, I think we can rule out screen issue.

Does this point towards the problem?
 

LondonJohn

Member
Feb 11, 2015
14
0
0
Visit site
Does it work in compact mode in both sides!? Now it gets interesting ... and personal :) :)
That's a funny software glitch.

Yes, "e" key works on both sides.

I changed back to full mode, and changed keyboards as well, just in case my eyes were deceiving me, and "e" key doesn't work any other way in Portrait. Grrrr...
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
I think there's some file(s) in the phone that relates letters and position in some way. I'll have a look. Have you ever messed around with root access?

I called a forum member for help. Stay put.
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
And another one :) Go to settings > apps > all > search for Google keyboard and uninstall updates and clear data. Reboot the phone. Make a test. Update the keyboard in the Play Store.. Test again.
 

LondonJohn

Member
Feb 11, 2015
14
0
0
Visit site
And another one :) Go to settings > apps > all > search for Google keyboard and uninstall updates and clear data. Reboot the phone. Make a test. Update the keyboard in the Play Store.. Test again.

Thanks again for your suggestion and for sticking with this :)

Unfortunately that didn't work - tried several times, but no joy :(
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
Run out of ideas mate :(

Just trying to postpone the factory reset. I'll be out for a while, carnival time!. I'll post if something else comes to my mind.
 

Trending Posts

Forum statistics

Threads
938,765
Messages
6,891,014
Members
3,156,386
Latest member
PaladinG