Edge USB Port ( fast Charging and mtp )

Dhruv Kataria

Member
Feb 1, 2015
7
0
0
Visit site
Hi ,
I have recently discovered two issues and was wondering if anyone else had the same

1. Phone doesnt do any fast charge with third party fast chargers ( auker and anker ) . It use to work fine and then stopped working and now it gives a beep/vibration like the power is going and stopping. It works perfectly fine with Samsung charger. Did samsung make a firmware alternation to limit third party chargers ?

2. Phone when connected to Laptop cant be detected as mtp.. tried changing cables/ usb debugging/usb configuration/cache clean/hard reset. the cables just work fine with tab a. So is the port gone bad.

can both these issues be related to a bad usb [port ? did anyone else have this issue ? any advice.. thanks
 

Dngrsone

Well-known member
Jan 17, 2013
321
0
0
Visit site
Yes, both issues could be caused by a damaged port: if one of the data pins in you're connector is compromised, then your phone would exhibit similar behaviors.

The only thing that seems weird is that the phone fast-charges with the Samsung charger.

With that said, as I recall, the phone looks for a specific voltage on one of the data pins which tells it that it is attached to a high-current power supply, so if that data pin is good but the other isn't, then it may recognize the Samsung charger but not the third-party ones which may be using an alternate methods of telling the phone that it is a high-current charger (This is purely speculation on my part).

If you have a magnifying device of some sort and a bright light source, I'd recommend talking a close look at your micro-USB port and make sure there isn't any dirt/debris/contamination in there that would prevent your cables from making a good connection with all five pins.

I generally have to blow out a little lint about once a year or so, even though I use cases with port-covers.
 

Tachead7075

Active member
Dec 14, 2016
32
0
0
Visit site
I think you might have a problem with your USB port.

My phone fast charges perfectly with all my Anker chargers(12V DC, 2 x AC, and wireless), the stock one, and connects just fine to my laptops.

Make sure fast charge is enabled in the battery tab. Make sure you are using a Qualcomm 2.0 or 3.0 certified aftermarket charger. And, try a different high quality cable. If that doesn't help, you likely have a problem with your USB port.
 

Dhruv Kataria

Member
Feb 1, 2015
7
0
0
Visit site
Thanks.. thats what I concluded myself.. USB port repair in the UK is 100 £ and I am just concerned if its opened once will it always feel the same :). Strangely no one else has had this problem.. thanks anyway
 

Forum statistics

Threads
942,976
Messages
6,916,710
Members
3,158,758
Latest member
davisongeorge