Erratic Charging

Majik Rat

New member
Jul 26, 2015
3
0
0
Visit site
I am sure this has been discussed before, but I am having a problem with charging my Nexus 2012. It is very erratic. One day it will charge fine, the next day it will barely charge at all. Same cord and charger being used. There seems to be no discernible pattern to this madness.

Now I have seen other reports of defective or loose USB terminals being the cause. I've also seen blame shifted to the OS itself. Has there been a consensus reached as to the primary cause of the charging issues? The combination of tiny screws, limited knowledge and fat fingers makes me somewhat apprehensive to bust her open and start fooling around with her innards

Having purged Lollipop from the device and gone to Cyanogenmod, the little device has returned to its former greatness. Now if I could just reliably charge it up . . . . Any suggestions?
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
26
0
Visit site
Has there been a consensus reached as to the primary cause of the charging issues?
Since this involves many different issues, there can't be a consensus on which one it is - it's different ones in different phones.

If wiggling the cable makes it charge, it's a loose charging port.

If the phone charges when it's turned off, but not when it's turned on, it's probably a motherboard problem.

If it charges okay, except when using certain apps, it's probably a battery at the end of its life.

The combination of tiny screws, limited knowledge and fat fingers makes me somewhat apprehensive to bust her open and start fooling around with her innards
The fact that you'll probably cause damage and turn a simple repair into an expensive one should concern you more.

Having purged Lollipop from the device and gone to Cyanogenmod, the little device has returned to its former greatness. Now if I could just reliably charge it up . . . . Any suggestions?
Determine WHAT the problem is first. You can't fix what you don't know is broken.
 

Majik Rat

New member
Jul 26, 2015
3
0
0
Visit site
Thanks for the reply. I always leave it powered on to charge it, sitting on a shelf. Here's the rub - it always says charging when in this state. However, some days after leaving it like this overnight, it will be recharged to 100%, other days it will have only increased its charge by 5-10%. This is why troubleshooting this has been particularly frustrating, because I cannot predictably reproduce the result. It's been a total crapshoot for me. Any additional input would be welcome.
 

UncleLes

Well-known member
Jan 22, 2013
85
0
0
Visit site
I have had a similar problem. I'm using the original charger and cord. Sometimes it would charge faster than others. I installed Dashclock widget (i've rolled back to 4.4.4) that includes a battery widget and sometimes i would see that it read Charging (USB) and other times Charging(AC). If, when I plug it in it says USB, which is a slower charging rate, I just unplug and replug until it says AC.

Don't know why this occurs, but I've solved the problem. Or least have an easy workaround.