fingerprintd - Restarting fingerprint sensor daemon


New member
Jul 27, 2017
Visit site
Hi at all here on the forum,

I have a quite rather frustrating problem. When I am trying to replace the fingerprintd binary in /system/bin the service can not be started again, resulting in a not functioning fingerprint sensor.
Not only when you try to replace it, simply removing the original fingerprintd file (eg. to the sdcard) and putting the original file back at /system/bin can not be started again.
I have tried to set the UID, GID right ("chown 0:2000 fingerprintd"), give the right file permissions ("chmod 755 fingerprintd"), but it will not start on its on or when you execute it manually.

Further I have tried to stop the service before i replace the file and then start it new, with the commands
"stop fingerprintd" and then "start fingerprintd". Didn't had the desired effect of starting the fingerprintsensor service.

For an example when you stop the gatekeeper daemon ("stop gatekeeperd"), you are not able to log in in your phone obviously, with "start gatekeeperd" it is possible again.
Unfortunately this behaviour can not be reproduced with the fingerprint daemon.

Another thing is when you kill the process ("kill [PID of fingerprintd or gatekeeperd]") the process will start automatically again, without doing anything, as long as it is the original binary and it hasn't moved around on the phone. A modified binary will not be started automatically.

How can I get android to restart the original fingerprintd service or even a modified version of fingerprintd?

for modifying I use
"adb shell" in the shell "su" then "mount -o rw,remount /system" to make the /system partition read and writable, and then I am copying the modified binaries from the sdcard

Device =LG Nexus 5X
Android =7.1.2
Build Number = N2G47Z
SuperSU Version =
TWRP Version = twrp-3.1.1-0-bullhead.img

Thanks for answers in advance!

Forum statistics

Latest member