Galaxy S3 I9300 : Bluetooth issues after 4.3. Custom rom?

syemon

New member
May 2, 2013
2
0
0
Visit site
Hi, I'm new here and on a steep learning curve with all things android so bear with me if you can.

I have a 9300 on o2 in rhe uk.

Since updating to 4.3 at the weekend I can pair with my factory car kit but it disconnects after 8-10 secs. Every time I press to connect it does the same thing.
So far I've deleted the pairings on phone and car.
I backed up my data and did a reset but it's exactly the same.

I've now rooted the phone and wonder if a custom rom may be an answer to my problem.
If there are any recommended roms to help me get tbe bluetooth back I'd be grateful. Also if there is any way for the bluetooth firmware to be rolled back or overwritten.

A bit of a long first post but hope there may be someone who can help.

Thanks

Posted via Android Central App
 

syemon

New member
May 2, 2013
2
0
0
Visit site
Well just to let anyone else know who might be in the same position regarding bluetooth.

I sorted the problem by flashing a CyaogenMod CM10.0 rom based on Android 4.1.2 and bluetooth works again.
Less bloatware and no Touchwiz and the phone is much faster than before.
 

Page Tyler1

New member
May 13, 2014
2
0
0
Visit site
After months of issues with my galaxy s3 and bluetooth disconnecting I finally did a factory reset. Now everything seams to be working correctly. I tried all the other suggestions like clearing cache, and booting in safe mood which where temporary fixes. The problem would comeback some times in days other times in hours. This was a complete fix. I also use a backup program and needed to only restore the data to the applications after they had been completely reinstalled. I also opted not to reinstall juice defender I can manage my power but I can't drive safely with out my Bluetooth.

I hope this helps someone.
Page
 

Trending Posts

Forum statistics

Threads
941,278
Messages
6,907,737
Members
3,157,843
Latest member
moh3_99