Galaxy S3 : Rooting Help

TXSTRiverBobcat

New member
Aug 3, 2013
2
0
0
Visit site
Ok so I just rooted my phone last night and I've had problems the entire way. I have the sprint Galaxy S3 and this is my first time ever rooting any phone.

So I started by finding and reading through several different instructions and videos on how to root, and i ended up using this method:

I started by downloading a .zip file that had Odin 3.04 I think and it also included a clockworkmod.tar in it and a superuser.zip in it. I then placed the superuser.zip in the internal storage on my phone and then put it in download mode. oh yea and downloaded all of the Samsung drivers. Then I opened Odin and I made sure that auto reboot and F. reset time were checked, clicked on PDA and selected the clockworkmod.tar file and opened it. So after Odin was set up and ready I plugged in my phone and after it popped up in the top left the way it should and was highlighted in blue, and the message box read added, I clicked start and it did its thing and said pass in green. My phone auto rebooted and then I turned it off and attempted to go into cwm recovery. I pressed the up volume, home, and power buttons and it went into the stock android recovery mode. I tried it again using the same process and it still didn't work. So I got on the galaxy s3 community in G+ and got some advice. I was told to uncheck both reboot and F. reset time and pull the battery after i get the Pass message. I did that and went straight into recovery without my phone rebooting. It went into cwm recovery mode just fine. I created a back up and let it finish then I navigated through the menu to install the superuser.zip. After it was installed I then rebooted my phone. I downloaded busybox and when I opened it I got an error that basically said my phone was improperly rooted and then it closed the app. So i downloaded rootchecker and it said that "sorry this devise doesn't have proper root permissions" or something like that. So I get back on G+ for help and I'm told to use a different superuser.zip. so I do that and start all over except with a different superuser.zip on my phone. This time everything works great and once I reboot I am able to install busybox and rootchecker says congratulations this device is rooted.

OK so I'm rooted now and have superuser permissions. I dont exactly remember how or what I was doing but I tried to get back to cwm recovery but it just goes to the stock android recovery. I tried downloading the official clockworkmod app and going to cwm recovery through the app but when it loads the recovery page its still just the stock android recovery,. I need help! The only way I've been able to get to cwm recovery has been by reflashing it using Odin and going directly into it without letting my phone reboot before I do.

So I need help because if I cant get into cwm recovery I can't really do anything. I would like to be able to flash different ROMs and stuff like that and from my understanding, the way to do that is to go into cwm recovery. Thanks in advance.
 

Trending Posts

Forum statistics

Threads
943,819
Messages
6,920,211
Members
3,159,250
Latest member
MRG582