Gear S3 Weather and S-Voice issues after upgrading S7 Edge to Nougat

arunma

Well-known member
Dec 3, 2015
1,537
43
48
Visit site
I'm using a Galaxy S7 Edge with a Gear S3 Frontier (4G LTE, T-Mobile version). I recently updated my phone from Marshmallow to Nougat, and for reasons I can't remember I was asked to re-install my Gear Manager. This necessitated a light factory reset of my watch as well, so that I could re-pair the devices. Since then, my device has worked just fine with two notable exceptions: the weather app and S-Voice's ability to call or text my contacts.

When I try to perform the "add city" function in the stock weather widget, I get the usual note about giving the device permission to access my location. I then get a "finding location" dialog. However, it causes my phone to freeze up for a few seconds. I've tried going into the gear manager and accessing the settings for the weather app, and I get the same freezing behavior on my phone. It's as though any attempt to access my location on the phone weather app (except for using the phone desktop widget directly) fails.

Separate from this, when I try to text one of my contacts, I get a "contacts syncing" message, but my contacts never actually sync. I've read other messages on this forum in which people suggest connecting to wi-fi or LTE. I've tried this to no effect.

Before I ask for suggestions, here are things I've tried:

- Uninstalling the gear plugin and light resetting the phone
- Uninstalling the gear plugin and hard resetting the phone
- Force stopping the weather app via the gear manager

So far nothing works. Any ideas?
 

SlackBlade

Well-known member
May 10, 2012
48
0
0
Visit site
I just got the S3 Classic, and the weather is not working. I also have a nouget S7 Edge (Sprint). I tried getting it to work on the watch, and I allow it, and I get a "finding your location" on watch, and and a "Gear S plug-in has failed", "Restart app". This is the first post I have found relevant to the S3.

If I try to access the weather setting on the Gear app on the phone, the screen goes white, and never does anything. Same if I press the gear ⛭ next to weather.

Any input by others would be great.
 

afh3

Well-known member
May 15, 2015
122
0
16
Visit site
Not sure about the weather deal, not having that issue.

But, I did get the exact same S-Voice problem -- the syncing message -- when I'd try to call/text a contact.

I performed a reset on the S-Voice app on the watch (it's in the watch app's menu) and it didn't seem to fix it, until the next day when it started working again.

Don't know if the two events were related, but it is worth trying.
 

Trending Posts

Forum statistics

Threads
942,848
Messages
6,916,204
Members
3,158,692
Latest member
BlueSun