New member
Jan 4, 2010
Visit site
I recently changed from a BB Storm to the Droid Eris, and for anyone who wants to know, best idea I've ever had.
But on to the point. I have had a gmail account for some time, and when I set up the phone in store, I gave them this.
Now when I use either the "mail" shortcut OR the "gmail" shortcut, neither of them will display my emails. I'm sure it's something simple that I just haven't figured out yet, but I would really like to be able to see my gmail emails on my gmail shortcut (similar to messages) and not in the notification bar.
So if anyone would mind helping a semi-noob, I would greatly appreciate it!


Well-known member
Oct 21, 2009
If I understand what you're saying is that you're getting notifications of new e-mails, but when you go to the gmail program on the phone the mail isn't showing up?

For reference the mail shortcut, the one that looks like a mailbox is only for use with other e-mail accounts, unless you specifically set up your g-mail account as an pop/imap account. ie didn't sign in with your g-mal account when you initially set up the phone.

Go into data synchronization - Menu > Settings > Data Synchronization > Google, are all the boxes checked?


Well-known member
Dec 9, 2009
Visit site
I had a somewhat similar issue this past week. Only my problem was gmail app wasn't working, but IMAP via mail message was working fine.

My issue via the gmail app was that I sent out too many pictures to my wife using the share function so google locked out my gmail account. I only discovered this days later when I tired to login to gmail via PC browswer, there I was routed to a notification and couldn't touch my gmail online. I emailed gmail linking my y ahoo account to fix this false lockout (they thought I was a spammer).

You may want to confirm via your PC that your not locked out.

alternatively re-setup your mail app settings.

1. open Mail app
2. select Menu > More... > Settings > Account Settings
3. Your gmail should be typed out collapse keyboward and click Next
4. confirm the following:
Protocal: IMAP
Email address:
Password: yourcurrentpassword
IMAP Server:
Security Type: SSL
Server Port: 993

Thats what you need for inbound email

outbount email is all the same except

SMTP Server:
Security: SSL
Server Port: 465

If you haven't setup your Gmail account to allow IMAP, which may be the issue as ERDude mentioned do the following:

To enable IMAP in Gmail:
1. Sign in to Gmail.
2. Click Settings at the top of any Gmail page.
3. Click Forwarding and POP/IMAP.
4. Select Enable IMAP.
5. Configure your IMAP client and click Save Changes.
Last edited: