Gmail Users: I Need Your Help

flyhighx

Well-known member
Nov 1, 2011
49
13
0
Visit site
I've been having a problem since day one with this phone where my incoming gmail is delayed drastically, sometimes up to 15 minutes or more. I've narrowed the problem down to whether or not the screen is on or off. If the screen is on, I get email instantly and in perfect sync with when my laptop or PC gets the email. Sometimes the phone even beats the computer by a half a second. This happens every time without question when the screen is on. However, when the screen is off, I get no notification for an extended period of time. I'll watch on my laptop as 3 or 4 emails come in and I'll get no notice on my phone until several minutes later. At that time, all 4 emails come across at once or I'll have to force the issue by turning on the phone at which time I'll finally get the email. Here are some details and what I've tried already:

-This problem exists on both my EVOLTE and my wife's so that reduces the chances that it's a flaw on just my phone
-It happens over 3G or wifi
-If the screen is off, and I know an email came through on my PC, as soon as I turn the phone on, the email will come through on the phone by the time I unlock it.
-Sync is set up correctly (as evidence by how well it works when the screen is on)
-I've cleared data, wiped cache, uninstalled and re-installed Gmail, factory hard reset, and have had this problem both pre-and post root
-I get this problem using Gmail or Mail as my default mail app (syncing to Gmail obviously)
-I've called both HTC and Sprint, Sprint refreshed data from their end and I've updated profile on my end. No solution has been found yet.
-I never had this problem on my OG EVO.
-Syncing should always work like it does when the screen is on.

HTC wants to swap out my phone, but I'm reluctant to do that because it's happening on both of our phones, I don't think that will fix it.

If you use Gmail, can anyone please try this: Make sure your phone's screen is off. From your PC, send a gmail to yourself. See if there is a delay between when your phone gets the email and when your PC does. If there is a significant delay, try it again with the phone's screen on.

Thank You
 

Cyrene

Well-known member
Jun 7, 2012
222
5
0
Visit site
Is your setting set to smart sync? I noticed that when I had this on, I would only get Gmail when I turned the screen on.

Sent from my EVO using Android Central Forums
 

wgregory

Member
Jun 8, 2010
16
2
0
Visit site
You're not imagining things. I've experienced the same exact issues since the day I received my phone. I've turned down offers to replace the phone because I'm convinced it's not hardware related since a couple of friends are also experiencing the same issue. I'm just holding out hoping that a forthcoming OTA update will fix this delay.
 

Mercury81

Well-known member
Jan 26, 2012
1,138
82
0
Visit site
I have my mail set to manual updates, double check all your mail settings ,make sure everything is selected correctly . Some people are not aware that there is a another setting in Gmail, once it's open click on lower setting bottom right . Then click on your Gmail address. Theres a bunch of different seething in there

from Evo4GLTE on Android Central
 

flyhighx

Well-known member
Nov 1, 2011
49
13
0
Visit site
Is your setting set to smart sync? I noticed that when I had this on, I would only get Gmail when I turned the screen on.

If you are referring to the smart sync disable app found in the market, no I haven't tried that yet. I've heard conflicting reports of it causing poor battery life, but I may try it. Thank You

You're not imagining things. I've experienced the same exact issues since the day I received my phone....

Glad it's not just me. Curious to see how many other people have this issue.

I have my mail set to manual updates, double check all your mail settings...

Thank you. I need to keep it on autosync though. Not manual. Some emails from work are time critical and I need to know I'm getting them right away. I did verify my settings though. I should be getting autosync and I'm not when the screen is off. When the screen is on, works like a charm.

Are you using the Gmail app or the default mail app?

I'm using the Gmail app, but I've tried it using the default mail app as well, synced to gmail. both give me the same results. Thank You though.
 

flyhighx

Well-known member
Nov 1, 2011
49
13
0
Visit site
Did you select auto sync from settings?

Yes, it is set. And again, it does work perfectly as long as the screen of the phone is on. If the screen is off, auto sync may be delayed as much as 15 minutes or more. It is definitely related to how the phone behaves in it's reduced power state.

I'd like as many people who use autosync and have a gmail account to try what I asked in my OP, thank you.
 

wgregory

Member
Jun 8, 2010
16
2
0
Visit site
As I mentioned earlier in this thread, I'm right there with you in my experiences when the screen is off and not receiving notifications until the screen is turned on again. However, the Gmail app is not the only one that seems to misbehave when the screen goes to sleep. I've noticed several other apps that used to quietly run in background and fire off notifications at specified times during the day, either get killed off altogether or fail to send the reminder at the time specified if the screen is asleep. It seems to me there are bigger underlying issues at play in how Sense 4.0 and/or ICS and these apps interact with each other on our new phones. I'm holding out hope for an OTA update to rectify the problem.
 
  • Like
Reactions: flyhighx

flyhighx

Well-known member
Nov 1, 2011
49
13
0
Visit site
Well, I tried the Smartsync Disabler app, turned it on, and rebooted like it said to do. I ran that for a while and I'm still getting the same problem. Not being able to receive emails promptly is terrible.
 

Mercury81

Well-known member
Jan 26, 2012
1,138
82
0
Visit site
I just had an email sent and I'm getting a flashing green light on top right sensor.:beer:;)
I just checked it's in settings, display & gestures, notifications flash, check mail
42575403-afb1-2b18.jpg

from Evo4GLTE on Android Central
 
Last edited:

flyhighx

Well-known member
Nov 1, 2011
49
13
0
Visit site
Yep, I have that checked too. Again, I have no problem receiving synced emails as long as my screen is on. Whenever the screen is off, email don't get delivered.
 

FaisDogg

Well-known member
Jun 4, 2011
546
11
0
Visit site
I've been having a problem since day one with this phone where my incoming gmail is delayed drastically, sometimes up to 15 minutes or more. I've narrowed the problem down to whether or not the screen is on or off. If the screen is on, I get email instantly and in perfect sync with when my laptop or PC gets the email. Sometimes the phone even beats the computer by a half a second. This happens every time without question when the screen is on. However, when the screen is off, I get no notification for an extended period of time. I'll watch on my laptop as 3 or 4 emails come in and I'll get no notice on my phone until several minutes later. At that time, all 4 emails come across at once or I'll have to force the issue by turning on the phone at which time I'll finally get the email. Here are some details and what I've tried already:

-This problem exists on both my EVOLTE and my wife's so that reduces the chances that it's a flaw on just my phone
-It happens over 3G or wifi
-If the screen is off, and I know an email came through on my PC, as soon as I turn the phone on, the email will come through on the phone by the time I unlock it.
-Sync is set up correctly (as evidence by how well it works when the screen is on)
-I've cleared data, wiped cache, uninstalled and re-installed Gmail, factory hard reset, and have had this problem both pre-and post root
-I get this problem using Gmail or Mail as my default mail app (syncing to Gmail obviously)
-I've called both HTC and Sprint, Sprint refreshed data from their end and I've updated profile on my end. No solution has been found yet.
-I never had this problem on my OG EVO.
-Syncing should always work like it does when the screen is on.

HTC wants to swap out my phone, but I'm reluctant to do that because it's happening on both of our phones, I don't think that will fix it.

If you use Gmail, can anyone please try this: Make sure your phone's screen is off. From your PC, send a gmail to yourself. See if there is a delay between when your phone gets the email and when your PC does. If there is a significant delay, try it again with the phone's screen on.

Thank You

I don't have this issued I'm getting real time push notifications with Gmail, yahoo mail app, Facebook with out any delay....I did customize bunch of settings when I did setup for the first time but don't remember what I changed to get it to work like it dose.

Sent from EVO 4G LTE
 

Mercury81

Well-known member
Jan 26, 2012
1,138
82
0
Visit site
I don't have this issued I'm getting real time push notifications with Gmail, yahoo mail app, Facebook with out any delay....I did customize bunch of settings when I did setup for the first time but don't remember what I changed to get it to work like it dose.

Sent from EVO 4G LTE

Mine is working perfect after a brief message yesterday . The message read "auto sync not able to perform at this time please try back later ",it started working about 20 minutes later.

from Evo4GLTE on Android Central
 

Mercury81

Well-known member
Jan 26, 2012
1,138
82
0
Visit site
I did as you suggested and had screen off. Mine is working perfect after a brief message yesterday . The message read "auto sync not able to perform at this time please try back later ",it started working about 20 minutes later.

from Evo4GLTE on Android Central



from Evo4GLTE on Android Central
 

Trending Posts

Forum statistics

Threads
945,915
Messages
6,927,686
Members
3,159,992
Latest member
Lilc73