Google Contacts won't sync

devo1929

Member
Jun 7, 2011
9
0
0
Visit site
Mouseglider's method does allow me to sync, but any contacts that I added to my account using my phone were wiped out because they were never synced to Google's servers.

I noticed something that else that may be causing the issue for others as it was for me. I was using Go Contacts EX app as my contacts manager app. If I use the stock contacts app to add a contact, it syncs to Google just fine. As soon as I add one using Go Contacts EX, following sync attempts fail.
 

Nathan Bliss

New member
Nov 18, 2012
1
0
0
Visit site
Thanks a lot for this information mouseglider. Following your clever and brilliant instructions for resolving gmail sync'ing problems with Android has caused me to lose most of my important contacts. Far from a successful sync resolution, this has caused a one-way sync from Gmail, which only had a fraction of the contacts that were on my HTC Wildfire. End result: Most of my important contacts are now deleted from my contacts list.
 
Last edited:

Rodrigo Pereira

New member
Dec 22, 2012
1
0
0
Visit site
Mouseglider's method does allow me to sync, but any contacts that I added to my account using my phone were wiped out because they were never synced to Google's servers.

I noticed something that else that may be causing the issue for others as it was for me. I was using Go Contacts EX app as my contacts manager app. If I use the stock contacts app to add a contact, it syncs to Google just fine. As soon as I add one using Go Contacts EX, following sync attempts fail.

That's MY EXACT problem. Whenever I add a contact using Contacts EX (edit, just tried to add a contact using the default Contact app instead of Contacts EX and the problem will also occur), my sync will just fail. If I remove all contacts and try to sync again, it will all work flawlessly. If I add a contact on gmail and sync, it will bring it to my phone, but whenever I try to change something on contacts EX, it won't work and the syncing will no longer work from then on.

That's a very serious issue and even though Contacts EX is updated, I've never had a solution to this problem. Does anyone?

Thanks
 

dwtubman

New member
Mar 8, 2013
1
0
0
Visit site
I just solved my sync problem sounds a lot like yours.
1-Remove or uninstall all samsung programs and applications you probably already loaded on it for your phone (USB driverand KIES 2 application software
withoutconnecting the phone. Also remove the KIES ar icon from the phon if it's there.

2-After rebooting your PC/MAC go bck t the Samsung.com.us/kies.com site and now try downloading the kies 2 version for your phone.
Ifit goes to tha error windw that says "you are notconnected to the internet (blah blah blah) keep hitting the retry button several times and it'll
likely continue to the end.
After KIES 2 completely loads up-close the browser and then using a usb cord connect your phone.
PC/MAC will then correctly recognioze it as a device and just follow the prompts till you eventually hae the kies icon on both comnputer and phone.
From this point I was home free-downloaded m 750 contacts-all my itunes music-every photo on my computer (drat) but ater 48 hrs of trying the key was restartin the computer BEFORE tring to use the phone connection.
 

Giovanni Belmonte

New member
May 4, 2014
1
0
0
Visit site
Easy Fix- I was having the same problem after using Go Contacts EX for adding new contacts and then not being able to sync. I downloaded the free app 'Contacts Sync Fix' from the Play Store, ran it once, and in a few seconds all the contacts FROM my phone had been synced TO my Google account. THEN I used the original suggestion from this thread of clearing the contact data from my phone's apps menu, then syncing from my G account back to my phone. And from them on I only use the stock version of Contacts to add new contacts. Hope this solves EVERYBODY's problems...
 

Bari Frankel

New member
May 10, 2014
1
0
0
Visit site
the below info to sync gmail..am I looking for menu /settings/ etc on my android or chromebook/gmail??


First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications" - look for menu/setting/acct and sync etc..ill find on GALAXY NOTE OR GMAIL??

Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

If you have problems with "calendar" and "gmail" do t
 

Chris Manning2

New member
Jan 11, 2015
1
0
0
Visit site
Try this:

First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"

It worked for me too! Thank you so much. It was a little different though because I don't have a menu option of "Accounts & Sync" under Home - Settings. But I figured out a work-around where I turned on "Restrict Background Data" from the "Home-Settings-Mobile Data" screen. Then, I just followed the rest of the instructions. I also did a couple other things like I went into my Contacts application, hit the menu icon and turned off "Auto Sync Data" from the "Accounts & Sync" menu there in my Contacts menu. I don't know which one did it- but I now have my Contacts synced and I can't thank you enough for yours, and everyone else's time and effort in posting your helpful steps.
 
Last edited:

mouseglider

Well-known member
Dec 11, 2009
462
25
0
Visit site
Wow!,

I just happened to see my post in 2010 - Android hasn't changed the menu setting to much from version to version - 5 years later, I am glad it still works!

Just remember that your contacts must have been first synced with Google, if your contacts were saved only to your phone's internal database and "NOT" on Google's database, then it will not sync and work as stated. Some "Non Stock" alternate apps may also cause problems, but should work the same. Android has improved over the past 5 years. :)

With that being said - whenever you add a contact to your phone you have a choice to save it to your phones internal database or Google - you should be able to to set the "Default" to save to Google only. If you save to your phone's internal database, you should find a way to backup your contacts as they could be lost following my instructions of clearing "data and cache".
 

klear6

Active member
Feb 14, 2016
33
0
0
Visit site
How long did you have to wait to see a change? Mine keeps saying it was synced over a month ago. I tried all the steps. Thankfully I backed up my contacts in case something goes wrong but this is driving me insane.
 

empire13

New member
Mar 31, 2016
1
0
0
Visit site
Hi Mouseglider,

Excuse my ignorance... where do you apply these steps?
Do these apply if my phone is rooted?

I'm not familiar with non-standard applications. :-(

Cheers!
 

Draesk

New member
Aug 1, 2016
1
0
0
Visit site
Mouseglider, you utter legend. It's the back-half of 2016, and this still works. The names of a few things have changed, and while the option to clear the data of the contacts app is no longer present, a force-close was evidently enough. Kicked the whole thing back into action.
 

werwasai

New member
Aug 29, 2016
1
0
0
Visit site
Try this:

First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"

Did exactly as you stated, had the sole effect of deleting all my contacts.
Thanks a lot.
 

Members online

Trending Posts

Forum statistics

Threads
945,952
Messages
6,928,035
Members
3,160,025
Latest member
5kaymann