Google Contacts won't sync

Ed Hughes

New member
May 19, 2010
1
0
0
Visit site
I can't get Google contacts to sync on my Sprint hero.
Gmail and calendar work fine.

But contacts won't sync...

Any ideas. It just times out and says sync not available now.
 

beezy

Well-known member
Feb 27, 2010
2,434
1,010
0
Visit site
I can't get Google contacts to sync on my Sprint hero.
Gmail and calendar work fine.

But contacts won't sync...

Any ideas. It just times out and says sync not available now.

Go to settings>accounts&sync>google>sync now. If that dont work uncheck/check sync contacts if it don't start to sync press sync now.If that fails reboot and it should sync.
 

markyflies

Active member
Nov 29, 2009
35
0
0
Visit site
Same here. Been that way since June 16. Gmail and calendar sync no problems. I'm sure a reset would fix, but I do not want to do that. I do not want to set up my phone again.
Can't wait until November. I will be going with a EVO
 

rynomite

Member
Sep 14, 2010
5
0
0
Visit site
Are you rooted?

If so, use rootexplorer to navigate to /data/data. Find the directory labeled "com.android.providers.settings" and delete it. Reboot, and your Google contacts should now sync!
 

mouseglider

Well-known member
Dec 11, 2009
462
25
0
Visit site
Try this:

First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"
 

pkn

New member
Feb 5, 2011
1
2
0
Visit site
thanks!

Try this:

First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"

This worked for me! Thanks!
 

jwgrenning

New member
Mar 1, 2011
1
1
0
Visit site
I've got a few steps to add

:D Thanks so much for the solution. T-Mobile wanted me to do a factory reset. :mad:

I thought I would fill in a few gaps in the menu and screen traversal

Home/Menu/Settings/Accounts & sync
Turn off Background data
Home/Menu/Settings/Manage Applications/All/Contacts Storage/Clear data

Home/Menu/Settings/Accounts & sync
Turn on Background data

thanks again, James
 
  • Like
Reactions: m.jrdn

smmoore2

New member
Jan 17, 2011
1
0
0
Visit site
Try this:

First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"

My problem is that the clear data button is greyed out. why can't I clear my data?
open the "Contact Storage" and click "clear data" of "Contacts Storage"
 

SSHGuru

Banned
Dec 15, 2009
658
64
0
Visit site
I got the Bionic and everything Sync's but the gmail contacts. I can't do those steps because the options are greyed out.

Any advice?
 

Vance14

Well-known member
Aug 17, 2010
727
47
0
Visit site
Mine still is having problems even after this fix. I have cleared all my data and it tries to resync everything, but then it just stops after a while and the small "syncing" spinning icon just goes still, but doesn't go away. And, new contacts from my browser UI are not synced into my phone. And, it is showing that the last sync was yesterday morning, even though it has tried numerous times since then.

Edit: after doing this process a few times, it finally did sync and shows a new sync date and time, but for some reason, the little icon won't go away. Regardless, it finally did sync!
 
Last edited:

docedt

New member
Jan 3, 2012
1
0
0
Visit site
Mouseglider's recommendation worked perfectlt. I had Sprint do hard reset and they re-entered contacts that had been saved not realizing that Google would re-sync contacts so I ended up duplicate set of contacts. This led to Evo not wanting to sync Google contacts. Thanks again for the tip.
 

hakimmmmm

Well-known member
Jan 14, 2012
245
14
0
Visit site
Try this:

thanks alot man
i tried so hard to get it sync n searched the net for hours but couldnt find anything

this forum and ppl like you rock

thnxx again

First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"
 

ben63vw

New member
Jun 30, 2012
1
0
0
Visit site
Try this:

First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"


@mouseglider

Thanks for the fix!!! :D Worked perfectly on my Samsung Captivate Glide with INC3PTION custom rom. It was the only thing not syncing after installing INC3PTION and restoring my settings from backup.
 

speedlever

Trusted Member
Dec 31, 2011
664
0
0
Visit site
Kudos to mouseglider for this fix. I've been struggling for a while trying to figure out why my Google contacts won't sync to my Galaxy Proclaim running GB. If I add new contacts to the phone and choose Google (instead of Phone) to save the contacts, the new contacts shows up in my Google contacts but weren't showing in my phone.

However, if I received a call from the new contact, the contact name would show up. But maybe that's caller ID instead of my contact list providing the info.

IAC, after following mouseglider's instructions, my contact list downloaded and I have my latest contact additions on my phone now.

Hopefully the sync will work as expected in the future.
 

Trending Posts

Forum statistics

Threads
946,026
Messages
6,926,208
Members
3,160,050
Latest member
chrshea