Google Play Store with multiple accounts - 403

GlennFS

New member
Mar 22, 2014
4
0
0
Visit site
Good morning

Have had an ongoing problem with error 403 in the Google Play Store.
In this case, the issue seems to have arisen because I have historically used 2 google accounts to purchase apps. 'Account A' from 4 to 3 years ago, and 'Account B' from 3 years onwards.

I now only have 'Account B' on my phone (N7000), however, some of the apps which I purchased with 'Account A' still appear as purchased in my Google Play Store, even although phone can be hard reset with no further 'Account A' reference. So I get this 403 download problem, although I wouldn't even mind just buying some apps afresh with 'Account B'. Also, maybe of relevance, the same card was used to purchase on both accounts.

Is there a way I can 'clear' the original 'Account A' purchases?

Any advice would be appreciated,
Cheers
 

SpookDroid

Ambassador
Jul 14, 2011
19,226
455
83
Visit site
Have you tried clearing Google Play cache/data from the App Manager? This would force Google Play to refresh the app list installed on your phone the next time you reboot.
 

GlennFS

New member
Mar 22, 2014
4
0
0
Visit site
Thanks for the reply. I cleared the data/cache as suggested for both Play Store and Services. Rebooted and unfortunately the same result. I had also formated the internal SD partition before I reflashed the ROM last night.

The two accounts I mentioned are also on different emails. The only thing that links them whatsoever is my name and payment card.

I wonder if the play store recognises the same payment details and assumes that there is no need to pay, even though the accounts are different (and cannot download).

I'll try changing the card details to another and see if that makes a difference.

Posted via Android Central App
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
26
0
Visit site
Try looking for a Google contact number and calling them. The people on that end of the server have a lot more control over what it can do than we users do.
 

SpookDroid

Ambassador
Jul 14, 2011
19,226
455
83
Visit site
Are you using any kind of software recovery software or backup after re-flashing the ROM? Or maybe, are the apps you're having trouble with already installed in the ROM? If so, that might be what's causing the issue...

Are the apps you're having issues with listed as purchased through the Google Play WEBSITE on your 'B' account?
 

GlennFS

New member
Mar 22, 2014
4
0
0
Visit site
No backup software installed, and no backup folders.

Logged in as account B. The website section of 'my orders' does not show the apps I want to install. However, the 'my apps' pages does show the apps as being installed, That were purchased from account A (and every other app I have ever installed and removed I think.)

The app I am trying to install first is Picsay Pro, which is not included within the ROM on my phone. Having installed CyanogenMod stable build. Although stock ROM produced the same results.

Get a new phone tomorrow, hoping that might be the solution. As the website Account A should have no reference to that phone.

Posted via Android Central App
 

Trending Posts

Forum statistics

Threads
941,401
Messages
6,908,643
Members
3,157,907
Latest member
lillly