Google search voice-activated application auto-launching- Why and how to disable??

Allen_B

Active member
Apr 2, 2013
30
0
0
Visit site
I have been experiencing a pretty frustrating issue and have no idea how to fix it.

This is for a 32GB One, (AT&T carrier). I use the phone to listen to music on a motorcycle, specifically to stream Pandora and I plug the phone into the sound system of the bike. Not sure how important it is but the only time this happens is when it is plugged into the bike so it seems odd that Voice search would do anything- I assumed the built in mic would be inactive since the phone thinks it is connected to a headset but I haven't tested that (just a thought).

The problem is that the phone will launch Google's voice-driven search application for no apparent reason. I have tried turning Google Now off and went into the "Voice" settings and disabled hotword detection but the app still randomly launches.

When the app self launches, the phone goes nuts cutting out Pandora, tries to dial various numbers (but typically is a re-dial of the last number). I am too new to Android to realize what is launching this and can't figure out how to kill or disable Voice Search. I have tried going to Settings-->Apps and all apps but I could not specifically find the Voice Search app.

Request assistance with disabling the Google Voice Search app or to set for on-demand launching only...

/r

Allen
 
Last edited:

Allen_B

Active member
Apr 2, 2013
30
0
0
Visit site
Re: Google Voice search auto-launching- Why and how to disable??

I may have confused the issue with how I posed the question...

I am talking about the voice-activated search app, not the "Google Voice" service for phone service...

How do I disable the voice activated search app?

/r

Allen
 

Gator352

Banned
Sep 11, 2010
3,742
50
0
Visit site
Re: Google Voice search auto-launching- Why and how to disable??

What I would do is go into apps in settings and find google search and uninstall the update. For some reason, 4.1 and the new google search updates don't play nice with each other.
 

Allen_B

Active member
Apr 2, 2013
30
0
0
Visit site
Re: Google Voice search auto-launching- Why and how to disable??

Never mind....

I think I have inadvertently discovered two issues-
- The audio cable must have a fault of some sort making the phone think it has a button-headset connected
- Jelly Bean apparently has locked the long-press function of a headset to launch Google Now

I'm guessing that the audio cable is shorting something, making the phone think it is getting various commands including a "long-press" thus launching the voice search. This is a guess but is the only thing I can figure out that makes any sense.

I'd still like to know if there is any way to disable voice search. Turning Google Now off did not fix the problem...

/r

Allen
 
Apr 6, 2014
2
0
0
Visit site
Hey everybody,

I've been experiencing this very very very annoying issue. Whilst listening to music at the gym, (i.e. only when I have headphones connected), Google Voice Search will just randomly launch and interrupt my music. Meaning I have to fish my phone out of my pocket, close it, restart my music... You can imagine how frustrating that gets whilst trying to work up a sweat!

Anyway - having searched everywhere for an answer, I noticed lots of people have the same problem. Disabling Google Voice search in SETTINGS: LANGUAGE & INPUT does not work.

HOWEVER - I have been playing around and I think I found a solution. It has worked so far - I am so excited and relieved, I registered on this forum so I can share it!

If you have the GOOGLE SEARCH WIDGET on any of your screens, DELETE IT.

This is the one I mean, at the top of the screen: download.jpg

As long as this widget sits on any of your screens, when you press long on the screen (even when screen lock is on!) it will launch GOOGLE VOICE SEARCH when you have headphones connected.

I guess when we are exercising (which is when most everybody reports this problem ironically) with the phone in a pocket or case, the continued vibration/pressure etc. launches the widget.

Hope it helps!
 

Miranda Betancourt

New member
Jun 29, 2014
1
0
0
Visit site
Mardi-Louise Van Heerden;3559149: A MILLION TIMES THANK YOU ! Your suggestion was the solution. Because of you i no longer wish to high five my phone with a hammer! You rawk!
 

Mark-1

New member
Jul 9, 2014
1
0
0
Visit site
Thanks for these posts, I often listen to music or podcasts using the headphone jack to plug into the car audio... this was driving me nuts too!

Rather than delete the widget, you can also disable it.

Go to Settings, Apps, and select 'All' to view all apps (not just those you have downloaded, which is the default view). Select 'Google Search' and then 'Disable'.

If you do it this way, you can at least keep the app/widget, & re-enable it if you want it at other times.

Hope that helps!
 
Last edited:

Dr4gonkiller96

New member
Oct 7, 2014
2
0
0
Visit site
Hey everybody,

I've been experiencing this very very very annoying issue. Whilst listening to music at the gym, (i.e. only when I have headphones connected), Google Voice Search will just randomly launch and interrupt my music. Meaning I have to fish my phone out of my pocket, close it, restart my music... You can imagine how frustrating that gets whilst trying to work up a sweat!

Anyway - having searched everywhere for an answer, I noticed lots of people have the same problem. Disabling Google Voice search in SETTINGS: LANGUAGE & INPUT does not work.

HOWEVER - I have been playing around and I think I found a solution. It has worked so far - I am so excited and relieved, I registered on this forum so I can share it!

If you have the GOOGLE SEARCH WIDGET on any of your screens, DELETE IT.

This is the one I mean, at the top of the screen: View attachment 111123

As long as this widget sits on any of your screens, when you press long on the screen (even when screen lock is on!) it will launch GOOGLE VOICE SEARCH when you have headphones connected.

I guess when we are exercising (which is when most everybody reports this problem ironically) with the phone in a pocket or case, the continued vibration/pressure etc. launches the widget.

Hope it helps!

Well part of that is the problem i headphones dont have a mic and when i take them out but not fully just so they are not fully in. With this i held it there still connectrd but just for a few secs and it launched google voice search to call someone and at the same time played music. It stupid
 

Ms Kateeba

New member
Oct 21, 2015
1
0
0
Visit site
I have been experiencing a pretty frustrating issue and have no idea how to fix it.This is for a 32GB One, (AT&T carrier). I use the phone to listen to music on a motorcycle, specifically to stream Pandora and I plug the phone into the sound system of the bike. Not sure how important it is but the only time this happens is when it is plugged into the bike so it seems odd that Voice search would do anything- I assumed the built in mic would be inactive since the phone thinks it is connected to a headset but I haven't tested that (just a thought).The problem is that the phone will launch Google's voice-driven search application for no apparent reason. I have tried turning Google Now off and went into the "Voice" settings and disabled hotword detection but the app still randomly launches.When the app self launches, the phone goes nuts cutting out Pandora, tries to dial various numbers (but typically is a re-dial of the last number). I am too new to Android to realize what is launching this and can't figure out how to kill or disable Voice Search. I have tried going to Settings-->Apps and all apps but I could not specifically find the Voice Search app.Request assistance with disabling the Google Voice Search app or to set for on-demand launching only.../rAllen
Go to Google Settings, then click on "Hands Free", go to headset and disable it. Had the exact same problem but this worked.
 
Last edited by a moderator:

bgbucks

New member
Jan 9, 2016
1
0
0
Visit site
My son was having this problem and we thought it was the lifeproof extenstion cord enabling Google randomly. He was very frustrated. Somehow the cord is inadvertently enabling Google through the voice activation feature. Simply go into your phone settings and find your way to the settings that disable "OK Google" feature. You can still use Google search on the widget by pressing the microphone manually or by holding in the bottom hot button key on the phone to pull up Google. You will simply lose the voice activation feature of "OK Google" which my son was completely OK with.
 

RefinedFrostSalts

New member
Apr 23, 2016
1
0
0
Visit site
Disabling Talk Back worked for me on lollipop and kitkat. Go into Settings/Apps/All/Talk Back -> disable.
It does not remove the "ok google" functionality, which I like, and you don't have to disable the google search app either.
It just stops the annoying, constant "to use google voice search, please unlock your phone" crap whenever I move my headphone lead.
I hope this helps. I made an account just to share this. It annoyed me for so long and nothing else worked without disabling google search.
 

Hsixbekahxkek

New member
Jun 21, 2016
1
0
0
Visit site
I have been experiencing a pretty frustrating issue and have no idea how to fix it.

This is for a 32GB One, (AT&T carrier). I use the phone to listen to music on a motorcycle, specifically to stream Pandora and I plug the phone into the sound system of the bike. Not sure how important it is but the only time this happens is when it is plugged into the bike so it seems odd that Voice search would do anything- I assumed the built in mic would be inactive since the phone thinks it is connected to a headset but I haven't tested that (just a thought).

The problem is that the phone will launch Google's voice-driven search application for no apparent reason. I have tried turning Google Now off and went into the "Voice" settings and disabled hotword detection but the app still randomly launches.

When the app self launches, the phone goes nuts cutting out Pandora, tries to dial various numbers (but typically is a re-dial of the last number). I am too new to Android to realize what is launching this and can't figure out how to kill or disable Voice Search. I have tried going to Settings-->Apps and all apps but I could not specifically find the Voice Search app.

Request assistance with disabling the Google Voice Search app or to set for on-demand launching only...

/r

Allen

For me first plugging in the headphones and then turning on the phone (from sleep, not completely off) seems to work. If I plug in the phone when the screen is on it seems to think I have a microphone on my headphones.
 

Remiix

New member
Jul 7, 2016
1
0
0
Visit site
Hey everybody,

I've been experiencing this very very very annoying issue. Whilst listening to music at the gym, (i.e. only when I have headphones connected), Google Voice Search will just randomly launch and interrupt my music. Meaning I have to fish my phone out of my pocket, close it, restart my music... You can imagine how frustrating that gets whilst trying to work up a sweat!

Anyway - having searched everywhere for an answer, I noticed lots of people have the same problem. Disabling Google Voice search in SETTINGS: LANGUAGE & INPUT does not work.

HOWEVER - I have been playing around and I think I found a solution. It has worked so far - I am so excited and relieved, I registered on this forum so I can share it!

If you have the GOOGLE SEARCH WIDGET on any of your screens, DELETE IT.

This is the one I mean, at the top of the screen: View attachment 111123

As long as this widget sits on any of your screens, when you press long on the screen (even when screen lock is on!) it will launch GOOGLE VOICE SEARCH when you have headphones connected.

I guess when we are exercising (which is when most everybody reports this problem ironically) with the phone in a pocket or case, the continued vibration/pressure etc. launches the widget.

Hope it helps!

Wow dude, I made an account just to reply to u, thank you for coming up with a solution, I have headphones in all the time, and when I watch YouTube or bike to work the voice thing pops up literally every 10 seconds. Anyway, thanks for playing around with everything for us all to find a solution!
 

Max_R98

New member
Jul 24, 2016
1
0
0
Visit site
I have been experiencing a pretty frustrating issue and have no idea how to fix it.

This is for a 32GB One, (AT&T carrier). I use the phone to listen to music on a motorcycle, specifically to stream Pandora and I plug the phone into the sound system of the bike. Not sure how important it is but the only time this happens is when it is plugged into the bike so it seems odd that Voice search would do anything- I assumed the built in mic would be inactive since the phone thinks it is connected to a headset but I haven't tested that (just a thought).

The problem is that the phone will launch Google's voice-driven search application for no apparent reason. I have tried turning Google Now off and went into the "Voice" settings and disabled hotword detection but the app still randomly launches.

When the app self launches, the phone goes nuts cutting out Pandora, tries to dial various numbers (but typically is a re-dial of the last number). I am too new to Android to realize what is launching this and can't figure out how to kill or disable Voice Search. I have tried going to Settings-->Apps and all apps but I could not specifically find the Voice Search app.

Request assistance with disabling the Google Voice Search app or to set for on-demand launching only...

/r

Allen


I have been experiencing this, and I believe I have the solution. Go to the Google app and go to settings. Click Accounts and Privacy. Then click Google Activity Control. Then go to Voice and Audio activity, and turn it off. I went to the history of my voice and Audio activity and it showed a bunch of times when it was used but there were no transcripts available. I believe it was showing all the times when it popped up randomly.
 

VK3_Photographix

New member
Aug 1, 2016
1
0
0
Visit site
I have the same problem with my Galaxy S6 Edge. However deleting the search widget didn't work. In my case it seems to be a headphone jack issue. When I plug headphones in, I have the problem. When I use Bluetooth headphones, it works fine. Of course the bluetooth phones drain the battery and the dongle swinging back and forth by my ear is a bit annoying.
 

Catfood86

New member
Aug 21, 2016
1
0
0
Visit site
Go to Settings, Apps, find Google App, and disable it. If it asks, if you want to replace the app with the factory version, just say yes, it will be disabled afterwards.
I have had the issue since I got my phone, I have tried all the above suggestions without success, but now this seems to have worked.
I have LG G3 with Android 6.0.
 
Last edited:

Members online

Trending Posts

Forum statistics

Threads
945,960
Messages
6,928,067
Members
3,160,025
Latest member
5kaymann