How to get rid of the '+' in my contacts phone #

boyer61

Well-known member
Feb 20, 2011
156
5
0
Visit site
I know facebook is doing this, But it adds a + to the beginning of the number, thus not allowing me to send a text message. How can i fix this?
 

FrankXS

Well-known member
Feb 27, 2011
3,143
401
0
Visit site
I don't know if this would work, but have you tried turning off (or adjusting, I guess) assisted dialing?

-Frank
 

Profireman25

Member
Feb 6, 2011
7
0
0
Visit site
It looks like the only way to remove the +1 is to add the contact in yourself.
My dad is having the same problem. Facebook adds the 1 for you, I have an htc inspire (AT&T) and i do not have this problem. I have already tried everything suggested here and thought I would see if anyone else was having this problem. Nothing I have tried has fixed this issue, anyone else have any ideas?
 

boyer61

Well-known member
Feb 20, 2011
156
5
0
Visit site
I tried disabling assisted dialing and it didnt work. I tried to add the number myself, but it will default to the one on facebook.
 

mikestorm

Well-known member
Nov 5, 2009
357
28
0
Visit site
I have a similar issue. I can't voice dial places of businesses (e.g "Call Pep Boys Auto" ) because of the plus prefix. Assisted dialing isn't the issue. Drives me crazy.
 

boyer61

Well-known member
Feb 20, 2011
156
5
0
Visit site
I've finally found the fix!
I sync all my contacts from Facebook, on the contact that has the +1 you need to create a new contact, with the name and # you want. It should link them together. Once linked, open the contact and long press 'call mobile'. You will now see an option to edit the #. Delete the +1 and save it!!

Finally! I was tired of getting error messages every rime I would text someone with a +1 in front of their #.

Sent from my Thunderbolt.
 

soboness5

Active member
Apr 2, 2011
41
1
0
Visit site
I've finally found the fix!
I sync all my contacts from Facebook, on the contact that has the +1 you need to create a new contact, with the name and # you want. It should link them together. Once linked, open the contact and long press 'call mobile'. You will now see an option to edit the #. Delete the +1 and save it!!

Finally! I was tired of getting error messages every rime I would text someone with a +1 in front of their #.

Sent from my Thunderbolt.

This would take forevvvvverrrrrrrrrrrrrrrrr. Can't Facebook fix whatever they changed on their end so the numbers are dial-able?
 

Mortiel

Well-known member
Mar 10, 2011
611
150
0
Visit site
This has been a known issue with Facebook specifically for over a year now. Not all Android contacts have +1 unless you have assisted dialing to prefix all numbers.

It actually has to do with location setting on your Facebook profile. When I moved from Ireland to the US and changed my location to USA, all my friends with US phone numbers went from +1 to just 1. However, some people that have created legitimate USA-located Facebook pages still for some reason think they are from outside the US, which creates the error. The contact is then synced to your phone, and non-Global phones cannot call internationally-prefixed numbers. Furthermore, since Android recognizes Facebook contacts as "live" contacts, their information cannot be permanently edited.

I have seen many cases where Facebook for HTC Sense will display the contacts correctly, where the Facebook for Android app will not.
 
Last edited:
  • Like
Reactions: FrankXS

Forum statistics

Threads
945,115
Messages
6,924,240
Members
3,159,667
Latest member
ab12shady