HTC One: USB not working

ranman505

Member
Mar 7, 2014
12
0
0
Visit site
I have a problem on my HTC and I was working through the answers and found yet another problem. My phone will show a notification to go download HTC sync Manager but it is never recognized by my laptop. I'm using both Win 7 Hm and Ubuntu. My wife has the same phone and when I plug it in it works! With her's my laptop beeps and shows up. I have developer settings set to USB debug on both phones. I've tried rebooting and resetting the phone also. Am I missing something else?
 
Last edited by a moderator:

AndroidProf

Well-known member
Nov 29, 2013
303
0
0
Visit site
Um don't know why it's doing that but you should try this method just for laughs. first uninstall the driver in the Device Manger and then press to update it >> then press Browse my Computer for driver Software >> then press on Let me pick from list.... >> in the list choose the Portable Devices >> choose MPT USB Drive. It should start working again.
 

ranman505

Member
Mar 7, 2014
12
0
0
Visit site
No workie. Checked all my USBs and can't tell which is the driver for my phone. Nothing says anything like HTC or whateverso don't know what to delete. I really think it's a phone problem. I reboot to Ubuntu and plung in my wife's htc one and it reads it. I noticed I am missing a app called "htc sync manager sync agent".
Her phone has it and I don't. I searched and can't find any info on it. Thanks for the replay though.
 

67GTV

Active member
Aug 11, 2011
26
0
0
Visit site
I think ranman505's issue can be resolved by enabling "Developer options" which thereby turns on "USB debugging" and MTP (Media Transfer Protocol). Here's what I put together from others' advice.

Enable "Developer options"

Settings > About > Software information > More > Build number >

Tap on "Build number" seven times. Developer options is turned on.

If you want this developer option to be turned off, then there is a slider on top of Developer options which you can click. The slider will move to off. This turns off developer options but it does not hide it from the settings menu.

Hide "Developer options" from the Settings menu

Settings > Apps > All > Settings > Clear data
 

ranman505

Member
Mar 7, 2014
12
0
0
Visit site
Thanks but when I stated in the first post "I have developer settings set to USB debug on both phones." I had already tried that. I just tried on my office computer running XP and it dos not work either. I really think it is the phone not the computer. My wife's phone has a app my phone does not called "htc sync manager sync agent". I really don't know how to get the app on my phone either.
 

thebignewt

Well-known member
May 11, 2010
395
12
0
Visit site
Maybe use a different synch app. I sort of hate the fact that this phone doesn't show up as disc drive on my Mac the way my Samsung GN did. I could drag/drop on that, not this thing.
 

VidJunky

Well-known member
Dec 6, 2011
5,545
322
83
Visit site
I found this site that says it is offering the APK for that app. Not sure if you have Outside sources checked or not, but if you try to install this and you don't it will ask you to turn it on. Here is the web page, the install is to the far right. There may be other sources for this APK but this was the first one I found. Also not sure why you wouldn't have it unless you have disabled it while disabling apps or disabled one that controls this. You know you always get that warning that disabling this app may cause other apps to stop working or what not. You will have to navigate to the site from your device and open there since you can't connect to a pc to transfer files.
 

ranman505

Member
Mar 7, 2014
12
0
0
Visit site
thebignewt I can't use anything because my phone will not work with any computer I plug it into a USB. I guess I can set up one of my servers to sync with wifi and then do resets. I did one hard reset but had to reenter all my info. I'll look into using one of my servers for that.
VidJunky Thanks I saw that and downloaded the apk and installed the app. Still didn't work. I think I need to a hard reset so I'll find some way to back up. I also went in and enabled everything I disabled just in case.
 

TBoltJ

Well-known member
Mar 29, 2011
412
12
0
Visit site
Try a different USB cord. Thats where all my troubles were. Are you using the same cord as when you plug in your wife's phone?
 

ranman505

Member
Mar 7, 2014
12
0
0
Visit site
Thought I'd bump this up again. STILL NOT WORKING. I can also plug a mini-USB stick into my wifes HTC one (m7) and see it on the phone using a file manager. On mine it never shows up.
 

drone3

Well-known member
Nov 16, 2014
630
0
0
Visit site
Same problem here, charging is fine but it can not be detected on any computer PC or Mac. I have checked every forum, tried every fix to no avail. I mainly need this function to transfer my camera roll, for now I'm using the Droid Nas app WiFi transfer.

Posted via Android Central App
 

jesseroo

New member
Mar 22, 2015
1
0
0
Visit site
Me too. I have looked at many forums now, tried many drivers, messed with my device manager, tried different computers, different USB ports, and different cables. NOTHING. By NOTHING, I mean NOTHING. My computer will not RECOGNIZE that anything happened when I plug in my M7 into it. Or, my M7 won't talk to my computer. It will charge, but it will not COMMUNICATE at ALL, so, whether it's the phone or the computer, the point is, NO communication between the devices via USB. SO frustrated. I am interested if anyone has come up with anything on the PHONE side of the issue. I'd even try an app if that would patch it up. I just want to move files from my computer to my phone, and USB seems like the best way, since we're talking about 13 GB of stuff.
 

PainterArt

Member
Mar 22, 2015
6
0
0
Visit site
Ok I think I figured this out or one possible reason. It worked for me. This was done with a Samsung but could be the same problem with the HTC

The problem is the device name change on your phone in About has change from the last time it was plugged into your computer. I had been playing around and the name had changed from "My Name" (SGH-M919) to "My Name" (SGH-M91.

How I got my computer to recognize my phone over the USB cable and so I could figure out the above name change problem.
On my phone under USB computer connection I changed from Media Device (MTP) to Camera (PTP). (note this may not be necessary). I then restarted (rebooted) my phone while still plugged in with the USB to the computer. Computer is on. As the phone booted up the computer started to install device. In the Device Manager it correctly installed Samsung Mobile USB Composite Device under Universal Serial Bus controllers and under Other Devices it had Samsung_Android with a yellow triangle !. On my phone I changed Camera (PTP) to Media Device (MTP) and my computer installed the correct MTP device driver. Phone can now be seen under Portable Devices in Device Manager and in windows Explorer.

No you probably do not have to do the camera/media device switch. If you change your phones name you and want to connect it to a computer you prior had connected the phone to you can do the reboot the phone while connected to the computer USB trick.

Just to double check my solution. I went back and change my devices name "My Name" (SGH-M919) and connected it back to my computer and the computer recognized it immediately.

I am sure this will make many people happy and keep their hair in their heads though I have lost mine. :)
 

ginjin

New member
Dec 5, 2015
1
0
0
Visit site
I turned on USB tethering and, after installing a lot of drivers, it worked. Now I have to find out what USB tethering is.
 

Reza0925

New member
Feb 9, 2016
1
0
0
Visit site
Hi Ginjin
I have recently faced the same problem as yours. Can you please let me know what I can do to solve it. I have tried lots of options without any luck.
Thank you

Cheers,
Reza
 

Andrew G4

New member
Sep 9, 2016
1
0
0
Visit site
Hi Ginjin
I have recently faced the same problem as yours. Can you please let me know what I can do to solve it. I have tried lots of options without any luck.
Thank you

Cheers,
Reza

I'm having the same issue with my m8. It's been like this for years. Nothing I do will make this phone show up in device manager. I've seen someone say it was ever since the lollipop update. I'm currently trying to flash stock marshmallow rom from Verizon to see if it helps. It's a little tricky without having USB.
 

xyz xyz

New member
Sep 11, 2016
2
0
0
Visit site
Here is what I have done to fix the issue: (htc m8)
- turn off the battery saving bellow notification bar
- go to airplane mode (turn off all connections)
- (optional) usb debugging I had also disabled (if you enabled it before in developer options)
 

xyzxyz132

New member
Oct 11, 2016
1
0
0
Visit site
And also change telephone name in settings->information about the phone to a name without any space, eg. "Brick" instead of "ugly brick"
 

Members online

Trending Posts

Forum statistics

Threads
941,300
Messages
6,907,866
Members
3,157,849
Latest member
Bule