Huawei p10 lite cannot recover


New member
Dec 31, 2018
Visit site
Hi there. I need help.
I have a Huawei p10 Lite which my grandson uses.
I have replaced front screen, back cover and frame and put everyhting back together. Phone woked fine, could make a back up with HiSuit (which I could not before as the screen was not wokring anymore so could give ok for connection) and go through apps. I deleted some after checking in Google Play what they were.
I was about to glue the back cover on when I thought it would be better to test the battery life in case it needed replacing as well and as I had the back cover off this wold be the time to do it (has to order one first though). I charged it and wanted the next day to keep it on to see how long it would last. However when I booted it up in the morning it would not boot up but went into recovery mode. I tried every thing to get it out, dowload recovery was-lx1a (c432) full a few times through the eRecovery mode which was succesful according to the screen message, it stayed in this rovery mode. Aslo deleting the cache and deleting all with going bac to factory setting did not working. Still the same. When I switch it on I get Rovery mode very single time and I have tried 2 dozen times by now.
Connecting to HiSuit does not help as there are not settings on the phone I can accept. When I install the drivers I can see the phone on my PC but only as a CD rom player so when I clikc it it says "please insert disk"..
How do I get this phone working again?
Is this onlya software problem or (also) a hardware problem?


Retired Moderator
Feb 12, 2012
Visit site
First, I assume you've recharged the battery again.

Second, it looks as if you have to reflash the ROM - the ROM order is Android, if that fails - recovery.

Try the Force Update method here, since you can't get to Android to do it the normal way.

Trending Posts

Forum statistics

Latest member