incoming caller-name is not displaying only number shows

jasonrego

New member
Nov 25, 2018
4
0
0
Visit site
I run few online stores and each store have its own support number; the calls are forwarded from the VoIP/phone service provider to my cell.

The VoIP/phone service provider add a prefix to caller-name to distinguish which number the call is coming to. When calls come to my cell it will show “Store#1 John Smith” or “Store#2 John Smith”. So when I take the call I can greet them accordingly to the prefix displayed from the caller name.

Recently I changed the cell phone form Galaxy S4 Mini to Galaxy A3 2017. Now I do not get the caller-name of the caller. All I get is the number the call is coming from.

How to make the phone to display the caller name also?

Some additional Details:
- These numbers or names are NOT stored in my cell
- Phone Samsung Galaxy A3 2017 with Android 8.0.0 Oreo; Fido (Canada)
- The issue must be at the phone as the prefix and names are displaying properly on other phones Galaxy S4 Mini.
- I have contacted service provider regarding this; the issue is NOT at the service provider level as its working fine on the Galaxy S4 Mini
- Caller ID is turned on the phone
 
Last edited:

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,982
5,297
113
Visit site
Welcome to Android Central! Open the Phone app, tap Menu>Settings>Call Settings, and look for an option for Caller ID. Is it turned on?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,982
5,297
113
Visit site
Have you asked your carrier about this? I wonder if there's something they have to do on their end for the phone.