"Installation failed" when trying to root 3t

RagingHammer

New member
Jun 2, 2018
1
0
0
Visit site
Hi. I followed this howto when trying to root my 3T

https://gist.github.com/edouard-lopez/44d14602e9c30490513b9f5aa12300fb

I've got the bootloader unlocked, and got TWRP installed, but every time I try to install a zip, it just fails. No explanation. "Installation failed" is the only info I get.

I tried install SR5-SuperSU-v2.78-SR5-20161130091551.zip, no luck. Then SuperSU-v2.82-201705271822.zip but same problem. Same also with Magisk-v16.0.zip,

Originally, I used twrp-3.2.1-0-oneplus3.img. Thought maybe I'd try an earlier version, so switched to twrp-3.1.1-2-oneplus3.img but still had the same problem.

I'm completely in the dark here, so any help would be appreciated.
 

ironass

Well-known member
Mar 9, 2015
5,196
517
113
Visit site
Hi. I followed this howto when trying to root my 3T

https://gist.github.com/edouard-lopez/44d14602e9c30490513b9f5aa12300fb

I've got the bootloader unlocked, and got TWRP installed, but every time I try to install a zip, it just fails. No explanation. "Installation failed" is the only info I get.

I tried install SR5-SuperSU-v2.78-SR5-20161130091551.zip, no luck. Then SuperSU-v2.82-201705271822.zip but same problem. Same also with Magisk-v16.0.zip,

Originally, I used twrp-3.2.1-0-oneplus3.img. Thought maybe I'd try an earlier version, so switched to twrp-3.1.1-2-oneplus3.img but still had the same problem.

I'm completely in the dark here, so any help would be appreciated.

Istall, free from the Play Store, Root Checker and determine if you are correctly rooted on Oreo.

You do not mention which .zip files you are attempting to install. Are they compatible with the OnePlus 3T?

The link you are quoting is almost a year old now and looks to be designed for rooting Marshmallow or Nougat.

Check out post #4 on the Oneplus 3T forums, here, for a more up-to-date rooting method for Oreo that is given in a step-by-step format with links to the latest downloads. If you have any further issues after following the tutorial, I would suggest posting there as they are very helpful.
 

fuzzylumpkin

Well-known member
Dec 7, 2012
5,554
2,562
113
Visit site
Sounds like it could be that your system partition is mounted as head only... Check that first, the simple solutions are often the correct ones.