Is this a fix for Sprint MMS issues?

jean15paul

Trusted Member
Jun 17, 2011
1,222
41
48
Visit site
I saw this posted on another forum, and thought I'd ask the smart folks here if this is safe and if it works.

I've seen a lot of complaints about MMS on Sprint recently. This is supposed to fix it. Original post: [Cm10] Discussion Of Nightlies - Page 37 - Google Galaxy Nexus CDMA Experimental Mod - CyanogenMod Forum - Page 37


Currently Running 12/14 nightly and I was having MMS issues with the stock messaging app as well. BUT I have fixed the issue. I'm not sure why this information isn't as widely availible, considering it was easy to do and works perfectly.

Despite what android tells you when you download those third party apps to edit your APNs, it's actually quite easy to edit them yourself; using the voice dialer. Here's a little step by step guide that I whipped up from several sources so I can't really take any of the credit for this information:

APN Settings for Sprint Galaxy Nexus running CM10

Function: Fixes MMS send and receive error. Also fixes Auto-Retreive!

Directions:
  • Go to Voice Dialer
  • Say "Open APNs" (Pronounce A-P-N)
  • Dialog will display open APNs, click it.
Now, create TWO new APNs by hitting the settings button on the bottom right of the touchscreen. Enter the information in the fields exactly like so (Please note that you must even enter the asterisks seen here, although you can leave the fields labeled as <not set> alone):

MMS Fix:

  • Name- Sprint
  • APN- cinet.spcs
  • Proxy- <not set>
  • Port- <not set>
  • Username- none
  • Password- ****
  • Server- *
  • MMSC- http://mms.sprintpcs.com
  • MMS Proxy- 68.28.31.7
  • MMS Port- 80
  • MCC- 310
  • MNC- 120
  • Authentication Type- <not set>
  • APN Type- mms
  • APN Protocol- IPv4
Hit the settings button when you're done filling out the fields, and hit save.

MMS over Wifi Fix:

  • Name- Sprint
  • APN- mms_over_wifi
  • Proxy- <not set>
  • Port- <not set>
  • Username- *
  • Password- *
  • Server- *
  • MMSC- http://mms.sprintpcs.com
  • MMS Proxy- 68.28.31.7
  • MMS Port- 80
  • MCC- 310
  • MNC- 120
  • Authentication Type- <not set>
  • APN Type- wifi
  • APN Protocol- IPv4
Save and reboot. Then you're done!
smile.png
Send an MMS to yourself to verify.

Someone telling me what to put in for a username and password make me a little nervous.
 
Last edited:

aktag

New member
Dec 20, 2011
1
0
0
Visit site
Not sure what phone you are using, but I have the Sprint Design 4G (Kingdom). I used ##3282# then went to edit (you will need your password, download MSC reader if you dont have the info - need root) settings, advanced, MMSC and used the settings in your post above. I also set the MMS server. It WORKED! I have been using the Heavenly Divine Rebirth ROM and have had thisissue since installing. Just thought I would let you know.

PS. I did not need to edit any usernames or passwords, just the server settings.
 
Last edited:

jean15paul

Trusted Member
Jun 17, 2011
1,222
41
48
Visit site
Not sure what phone you are using, but I have the Sprint Design 4G (Kingdom). I used ##3282# then went to edit (you will need your password, download MSC reader if you dont have the info - need root) settings, advanced, MMSC and used the settings in your post above. I also set the MMS server. It WORKED! I have been using the Heavenly Divine Rebirth ROM and have had thisissue since installing. Just thought I would let you know.

PS. I did not need to edit any usernames or passwords, just the server settings.

I'm on a Sprint GNex. I've had intermittent MMS problems on the stock ROM, on Are-You-Jellin (AOSP ROM), and now on CyanogenMod 10.

I ended up doing the same thing, entering the server settings without some of the other stuff. I seems to be working but I'd still like some more info since I've never messed with APNs before.

Sent from my Galaxy Nexus using Android Central Forums
 

Dhickory

New member
Jan 14, 2013
2
0
0
Visit site
Would this work for an Evo 3d? Been having mms issues since I rooted/s-off'd. Tried flashing fixes. Nothing ever works except using go-sms, but I just want to be able to use stock.

Will try this out anyways.

Thanks.

EDIT: This did not work for me :'(
 
Last edited:

jean15paul

Trusted Member
Jun 17, 2011
1,222
41
48
Visit site
Just to be clear. I entered everything per the OP except the entries with the *'s and the ones that said "not set". It definitely improves my ability to send and receive MMS messages, but it doesn't seem perfect.

I've clean flashed ROM updates a couple of times, and of course a full wipe deletes the APNs. If I don't go back and make this change it's almost impossible for me to send or receive MMS. With this change it works most of the time (maybe 85%). Even when it does work, it's still MUCH slower than it should be. (It might take 60 - 90 seconds to download a MMS that is only 8 words.)

This is with my GNex running CM10.1.

Sent from my Galaxy Nexus using Android Central Forums
 

jean15paul

Trusted Member
Jun 17, 2011
1,222
41
48
Visit site
so what am i supposed to put in for server and credentials instead of *'s?

The instructions in the post where I found this say to enter the asterisks exactly as they have them. When I did it I left "Proxy" "Port" "username" "password" and "server" completely blank (Did touch them at all) ... (the entries with "*" "not set" or "none")

It seemed to help with but still wasn't as reliable as it should be. Your mileage may vary.

This was a long time ago, in June (2013) I've gone back to Sprints stock ROM. I did a full restore from the factory .img files. (I did re-root after.) Since I went back to stock, MMS is working for me reliably on the latest stock ROM (GA02). I guess Sprint has finally got their stuff together.
 

Trending Posts

Forum statistics

Threads
941,583
Messages
6,909,517
Members
3,157,976
Latest member
fitcapsule3