JIT enabled htc hero 2.1

jus10o

New member
Mar 4, 2010
1
0
0
Visit site
Read before jumping into it
You can skip the benchmark part, but this is what Iv come across and had errors with while using jit. Could save future problems by reading.

I followed these steps. Originaly for the milestone android phone but it worked.
It will work on htc sense but it force closes alot, you cant swipe so you have to press home and change screens that way.
I am using it on the helix launcher with no problems and its running very smooth so far. I have been running it for about 24 hours now, and havent had any issues. Other then my network will turn off, i just have to toggle it off and make on and it works. But very rare if it happens.

USE the Menu key to unlock the phone. It seems to dislike sliding.
Or use Lock 2.0 or similiar so you can avoid using Htc lock screen. JIT dislikes htc programs.

Test 1 - Higher the Better
**Linpack - Jit disabled: 2.4 mflops
**Linpack - Jit enabled: 3.4 - 3.595 mflops average

Test 2 - Lower the Better
**Benchmark Pi - disabled: 12980 ms ___(My personal best before running with Jit)
**Benchmark Pi - enabled: 9156ms average/ Personal best 8981

Test 3 - Higher the better
**Neocore - stock: No idea
**Neocore - Jit enabled: 27.5 fps ____(I dont know my jit disabled number so I cant tell if it increased on my personal rom)


JIT is in no way perfect on our htc hero's so MAKE A BACKUP before trying.
And you could very well run into TONS of problems, its just something to test out.

Download: *vmlibs.zip
Then follow these steps:
?Create 2 folders on your sdcard: ?jit? & ?dalbk?
?Extract the vmlibs.zip to the ?jit? folder on your sdcard

?Using ADB pull your build.prop

ADB pull /system/build.prop build.prop

-It will place the file in your c:/android/tools folder
-Edit this using notepad or similiar program.
?Add the following line to the end of the build.prop: dalvik.vm.execution-mode=int:jit
-Save the changes and move it to the directory c:/
?Push it back to your ?jit? folder on the sdcard

ADB push C:\build.prop /sdcard/jit/build.prop
ADB shell
$ su
# mount -o remount,rw -t yaffs2 /dev/block/mtdblock6 /system
# cp /system/build.prop /sdcard/dalbk/
# cp /system/bin/dalvikvm /sdcard/dalbk/
# cp /system/lib/libdvm.so /sdcard/dalbk/
# cp /system/lib/libnativehelper.so /sdcard/dalbk/
# cd /sdcard/jit/bin
# cp -f dalvikvm /system/bin/
# busybox chmod 755 /system/bin/dalvikvm
# cd /sdcard/jit
# cp -f libdvm.so /system/lib/
# cp -f libnativehelper.so /system/lib/
# cat build.prop >/system/build.prop
# chmod 644 /system/lib/libdvm.so
# chmod 644 /system/lib/libnativehelper.so
# chmod 666 /system/build.prop
# sync
# mount -o remount,ro /dev/mtd/mtdblock6 /system
# reboot


TO DISABLE:
CHANGING THIS IN build.prop... This should disable JIT (Test and confirmed working)

dalvik.vm.execution-mode=int:jit

To:

dalvik.vm.execution-mode=int:fast

View attachment 651
 

Forum statistics

Threads
945,124
Messages
6,924,290
Members
3,159,672
Latest member
teneika lee