Maxx 4.4.4 Video Playback Issue - Hardware or Software?


New member
Oct 19, 2014
Visit site
Received a refurbished 32 GB Droid Maxx from Asurion after receiving two defective Razr Maxx HDs.

Phone came from Asurion with 4.4.4 already installed.

Have tried:
1. Factory wipe.
2. Cache partition wipe.
3. Re-flashed with stock 4.4.4.
4. All possible iterations of disabling/uninstalling/re-installing/clearing data/testing in safe mode of apps listed below.

Persisting Issues (apply to updated and stock Motorola camera app, Google camera app, YouTube, Gallery app, Photos app, Mxplayer, and test for video capture and playback using com server app in factory mode):

1. Phone frequently freezes during video capture to the point of requiring forced reboot.
2. For videos that are successfully recorded, when viewing preview in Gallery or Photos app, groups of blacks pixels appear as artifacts.
3. When attempting to play videos in any of above listed apps, I often get the message "This video could not be played," either right away or after some of the video plays (changes from attempt to attempt for same video).
4. When a video does successfully play in any of the apps listed above (including YouTube videos and in factory mode- com server video test), prominent artifacts in the form of: groups of black pixels similar to in #3;large, lingering "ghost" frames; and "glitch-like" events occur in every video. Occurrence is different in type and degree for each playback instance of the same video.
5. Additionally for YouTube, when playing a video embedded in a webpage (have only tried this in chrome), video is a scrambled mess of gray-scale bars (note all playback and viewing of previews in #1-4 retained color). Note that no problems have been observed with audio.

**Note that the "still camera" works perfectly fine and gallery apps show no artifacts in displaying still images.

A tech at a vzw corporate store said it was a "pixel density issue," but he had no idea how to fix it or whether it was a hardware or software issue. I take what he said with a grain of salt.

Asurion has no more new Maxx's in stock, and they refuse to send me another refurbished phone since they have already sent me 3. Since I am hard-pressed to give up the 32 for the new 16 they are now offering me, I would appreciate any ideas or assistance in determining the cause of this issue and possibly a fix if it is software-related. Thank you!
Last edited by a moderator:


Trusted Member
Jan 3, 2010
Visit site
I don't have any of these issues with my Maxx. I'd guess that if it still has the problem after you try a factory data reset, I'd suggest that it has a hardware problem.