MOTO X-PLAY: SD cards slow? SD cards shredded? Ghostdata on SD cards?


Jul 8, 2016
Visit site

I am at my wits end. Looking for help to understand and fix the issues with my Moto X-Play, SD Cards, and Marshmallow, maybe even Windows adds to the complexity here. This is the story - the earlier parts may not be 100% accurate:

December: Bought Moto X-Play 16GB (my carrier doesn't offer a 32 or 64 GB model, I wished they did) and shortly thereafter in a 128 GB Samsung EVO+ . This is a class 10 card, as recommended by Motorola. I pop it into the device and get the message: This card is slow blablabla .... I am thinking WTF???!!!! .... this is a class 10 card, what more do you want? Further research indicates that with a w/r speed of 80/20, this card might not be top of the line class 10. I chose to use it nevertheless and decide to just use it for certain non-critical apps and for the storage of photos and stuff. I install ES File Explorer. I am seeing the SD card, I am able to install some apps there and put some media files on it.

End of January: I am updating to Marshmallow and leaving the country for 3.5 months (I am mentioning this because you might wonder why it took me so long to deal with this ....).

At some point, I am running out of space for photos. I notice that I can't access the SD card. It shows in Settings/Storage & USB, but I can't drill down. I can also see it in ES File Explorer, but again, can't access the sd card's file structure. I am trying different File Explorers (Solid Explorer), to no avail. I end up manually deleting the photos after back-up, but this issue keeps occurring:

1: I can't move the photos from the internal storage to the SD card, despite the SD card showing in Storage &USB
2. I can't set the photo application to saving the photos directly to the SD card

May: Upon my return, I am talking to Motorola about this. During the chat they get me to adopt the SD card as internal storage. At first, nothing changes: I am not seeing the SD card capacity added to internal storage. I think it took restarting the device for the full capacity (16 + 128 GB) to show both in Settings/Storage and Solid Explorer (I dumped ES, terrible with all the ads).

June: However, I do notice that the device is somewhat sluggish now. I am traveling quite a bit and the phone is my main means of connectivity, I want to improve the situation and decide to buy a better SD card (Sandisk Extreme + 64 GB, [95/90]).

a) I unmount the 128 GB Samsung SD card.
b) I install the 64 GB Sandisk as internal memory, which seems to work
c) I try reformatting the 128 GB SD card for further usage on my Windows 7 desk top: the drive is visible in Windows Explorer only intermittently. It cannot be accessed in any way ("Insert disk into drive"). I try the same thing with my Windows 10 laptop (upgraded from Windows 8): the drive is not visible at all. I am trying two different adapters. Just for the sake of curiosity, I try the same thing with the 64 GB card: same result – invisible to Windows. An old 16 GB card works fine with the adapters and is visible and accessible in Windows Explorer.

That same night, a part of the tray that holds the SD and SIM cards pops off. I bring my device to the carrier for repair. I tell them about the SD card issues.

July 8: My carrier admits to having lost my phone. They give me a new one (and want to charge me $150 for a new phone .... WTF?????!!!!! The device is under manufacturer's warranty AND I have an extended warranty plan AND you lost it!)

I am setting the new phone up, with the 64 GB card in it. The device lets me know that the card is slow. WTF??????!!!! So, I am talking to Motorola wanting to know why.
a) I can't format neither the 128 nor the 64 GB card. Did Moto X-play render them useless? I am told I should be able to reformat them. They have no explanation why they do not appear in Windows Explorer "It depends on the pc". (I tried two already).
b) my device now thinks that a highspeed class 10 UHS-1 rated card is still too slow. I didn't get that message the first time I installed it (into the old device). If that is really true, then what type of card should I be using? I don’t get an answer to that.

We reset the device twice:
1. Without card in it through Settings/Backup & reset/Factory data reset. In Settings/Storage & USB, the cards shows as unsupported.
2. With card through Recovery Option after powering the device off. The card still shows as unsupported.
Motorola sends me back to the carrier to have them send the device in for repairs. (I am thinking I might be caught in a novel of Kafka).

The guy at the carrier’s kiosk goes into Settings/Storage & USB card. Despite the ‘unsupported’ status, he chooses the sd card and is able to format it as internal storage. All looks good. (I didn’t look at the values of storage used at the time).

I go back home and decide to start all fresh, instead of restoring the back-up of my old device from Google drive. After having installed most of the apps that I used to have my previous device, the new one is showing 26.80GB used. WTF????!!!!! These are less apps than I had before on 16 GB internal storage and NO APPLICATION DATA, NO MEDIA FiLES.

I check under Settings/Storage & USB:

Device Storage: 26.80 GB
Android OS: 5.11 GB (this looks normal)
Internal storage: 3.01 GB used of 10.89 (this looks normal)
Apps: 2.59 GB
Cached data: 22.63 MB
SandDisk SD card: 18.67 used of 58.53 (that doesn’t look normal)
so here is what the device sees there:
Apps: 1.21 GB
Images: 6.60 MB
Videos: 4.00 KB
Audio: 20.00 KB
Other: 3.43 MB
Cached Data: 43.03 MB
this means there is de facto less than 1.5 GB in data on that SD card, but the device sees 17 GB more. I am not even talking about the 5.5 GB that seem to be missing from the card's label value of 64 GB.

So … what to do? :confused:
a) About the 64 GB SD card - How can I get rid of the ghostdata?
b) Should I configure as internal storage and if not, how can I get photos to directly save to portable SD card?
c) About the 128 GB SD card? Return to retailer? It’s still under warranty.
d) Get a new SD card with even better specs?

All leads appreciated.


Well-known member
Nov 20, 2012
Visit site
So where are you at now with your situation? My problems are minor in comparison to yours, but nonetheless I am experiencing some strangeness... I have a few apps that keep uninstalling after I reboot my Moto X pure device!!

Trending Posts

Forum statistics

Latest member