Need help with an Asus Zenfone 5 ZC600KL X017DA stuck on Asus logo

lee Hawk

New member
Nov 2, 2021
2
0
0
Visit site
I have an Asus ZenFone 5 ZC600KL X017DA that is stuck on Asus Logo when turned on

Steps I have taken is to try a factory reset via the power and volume keys but all I get on the display is CSC fastboot mode

I have tried using minimum ADB fastboot tools and phone is detected as it's serial number will appear

I have downloaded 2 firmwares first one is using fastboot commands but during the process it will deny and state it's write protected

Another firmware was a CSV firmware again with fastboot options while running the commands there was more activity compared to the first firmware as in more information appeared but the end result was the same failed because partition is write protected

Based on some research it's suggested that the bootloader is locked and apparantly the only way to unlock it via commands is by enabling USB debugging. And for the obvious reasons I cannot enable it because phone won't boot

As it's a Qualcomm based chooser I was recommended to try using the Qualcomm flash tools but when following instructions I kept getting error but one thing I noticed in some instructions is that using the Qualcom flash tool the file extension I need is an MBN file but what appears when browsing for the firmware are .EFL file extensions

Further research says that for different type flashing methods have different firmwares ..

As I cannot use fastboot mode due to it possibly being locked I need to be able to do the flash using the EDL mode

I think I have gone through so many searches that I have ran out of options

So am hoping someone on here could point me in the right direction with some simple step by step instructions ( easiest the better ) and the relevant firmware for the flashing method

Oh yes before I forget I did try using the Asus ZenFone flash tool but every time I try to connect the phone in EDL mode the tool just freezes

Any assistance would be most appreciated and thank you in advance
 

lee Hawk

New member
Nov 2, 2021
2
0
0
Visit site
Need help with an Zenfone 5 ZC600KL X017DA flashing

Hello all

i have a phone that is stuck on Asus logo when turning on and will not go any further i have tried the traditional powe plus volume buttons to try access the usual factory reset options but no options all that will appear on the screen is CSC fastboot Mode !!! long press power key to shutdown device

so i went ahead and downloaded firmwares and did a little research apparrantly i should be able to flash over the firmware using mimimul ADB Fastboot but when following the instructions given i get the result write protected

the last one i believe was meant to be used with Qfil /QPST

i am kinda stuck here and would appreciate any help possible with instructions that are easy to follow (( apart from throwing it out the window ))

PS i would put details on here but seems this site flagged my first attempt as spam when showing a readout of the fastboot info and listing the firmwares

many thanks
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,500
4,641
113
Visit site
Welcome to Android Central! I merged your duplicate threads.

You can try including that fastboot info again, and we see the forum software automatically flag it, we can approve it.

You may also want to try over on the forums at XDA-Developers.com, where it's a bit more geared toward this kind of thing.
 

Forum statistics

Threads
942,855
Messages
6,916,236
Members
3,158,699
Latest member
rock09