• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

Need help with operating system

Insane Galvatron

New member
Jul 21, 2013
Okay, here's what happened. I rooted my LG Revo back when I first got it mostly so I could use the android tether and get around Verizon trying to charge me to use it as a hotspot ( I'm already paying for the unlimited data, why should I have to pay again? ). I used a one-click-root from the xda boards. Unlike when I rooted my Droid X before that, this time it installed Clockwork Mod Recovery. I only discovered this when my phone tried to automatically update. I had to "freeze" the auto updater to keep my phone from coming up in recovery mode during the night while I sleep. Not a big problem. Fast forward to now. I bought a new phone and was going to give the Revo to my daughter. I tried to do the factory reset from the android system ( had forgotten all about clockwork, even though I don't know much about it to begin with ). When it unpacked everything and then rebooted, it came up in recovery mode. Unlike when it did the update, just clicking "reboot phone" doesn't bring it back into the Android system. It's stuck in recovery mode.

I figured it was because it had uninstalled the software in order to reinstall it, but instead of launching it's own recovery mode and installing the software, clockwork mod recovery kicked in and now I just have no way to get to the original ROM that is undoubtedly still in the phone. So I figure I need to install a whole new ROM. As if the phone is a blank slate. So I take the SD card, put it in a different phone, download BrokenOutRevo and put it on the card, then put the card back in the Revo, and install zip from sdcard. It says it's installed, but yet the phone still only boots in CMR. So I figure that must be a bad ROM. Then I find GingerVolt which is supposedly better. Try again with the same result.

From what I gather, the phone has to have a working ROM in order to install a new one. Can anyone help me to get one installed while there is currently nothing installed? Or is it that my problem is something else? I'd be happy just to get back to the factory ROM if anyone can help me figure out how to do that. Otherwise, my daughter will be stuck with the LG Ally. Help me please!