Nexus 5: Should I use Global, LTE, or 3G

MrToneBoneZ

Member
Dec 27, 2012
13
0
0
Visit site
Greetings. My issue is that I recently went from a gs3 to 32gb nexus 5 on sprint and more often then not my phone is not receiving calls. People have said they called me 4 times in a row and the phone rang but on my end the phone didn't ring and I would just receive a voicemail notification. I live in an area with LTE as well. Has anyone experienced this issue ? Should I leave the phone on global, LTE or 3g, my main concern is I sing want to miss anymore phone calls. Thanks!

Posted via Android Central App
 
Last edited by a moderator:

krifor03

Well-known member
Nov 6, 2009
145
0
0
Visit site
This issue has been experienced before. I believe the short term fix is keeping your phone in 3G, not 4G.

Nexus 5 4.4.2
Got sideload?
 

Jaramie10

Well-known member
Feb 4, 2014
149
0
0
Visit site
I have experienced this in Nc. Turn your phone to LTE or 3g, we had to turn our phones to 3g to make a call. We are heading to T-Mobile, I'm done with this crap...

Posted via Android Central App
 

MrToneBoneZ

Member
Dec 27, 2012
13
0
0
Visit site
Ok so I'm not the only one experiencing this. OK thanks for the advice I'll give 3g a shot. I wonder if this bug will be addressed via update or it is a hardware issue.

Posted via Android Central App
 

bjrosen

Well-known member
Mar 19, 2011
751
3
0
Visit site
Did you buy your phone from Sprint or from Google? If you bought from Google then switch to AT&T, much better coverage and LTE speed. I'm on AT&T and I'm not having any problems liek you describe except when I inadvertently silence the ringer (which is pretty easy to do with this phone).
 

Jaramie10

Well-known member
Feb 4, 2014
149
0
0
Visit site
What's funny is that I decided to try a pretty paid account with T-Mobile and all the issues with the phone went away. I now have voicemail notifications, better battery life, crystal clear voice quality, and blazing speeds.

Posted via Android Central App
 

IAmSixNine

Well-known member
Jun 1, 2010
3,157
72
0
Visit site
I left Sprint a little over a year ago when i started to have the same issue with my GS3 and then my EVO LTE.
It wasnt a phone issue but rather their Vision Network upgrades that was causing it. Ive also read on other device forums that its happening to other Sprint customers. Missing calls seems to be on the rise. Hope they get it fixed.
 

Members online

Forum statistics

Threads
945,126
Messages
6,924,297
Members
3,159,674
Latest member
Cloud Himalaya