No photos or videos loading off wifi!

Jadon Hart

New member
Sep 30, 2018
2
0
0
Visit site
I have a Pixel 2XL and have had issues with my network connectivity these last two weeks. Initially I realised that my phone wasn't recieving text messages (sending okay), and then a few days later I noticed that media (both pictures and video) isn't loading on a lot of websites/apps when I'm off wifi (perfectly fine on wifi). It is most notable on facebook and instagram where no photos or video load (although thumbnails seem fine. Some websites and embedded emails don't load properly either. Then miraculously I suddenly received every text message from the last 2 weeks yesterday all at once, although media still not loading. Since then I have tried clearing cache and cookies, restarting phone and also resetting network settings. Anything else to consider?
 

TraderGary

Trusted Member
Apr 12, 2012
3,056
54
48
Visit site
Welcome to the Android Central Community, Jadon!

When connected to your network WiFi, what is your Internet speed?
I use the Speed Test app by Ookla to determine my current speed.
 

GSDer

Well-known member
Jan 30, 2011
8,471
15
0
Visit site
Anything else to consider?
Have you tried rebooting into Safe mode to see if the problem still occurs? Perhaps you have an application that's restricting your data usage?
Speaking of data, what kind of cellular connection do you have when this occurs? Solid LTE?
Are you sure you haven't enabled any system settings to prevent data usage?
 

Forum statistics

Threads
941,253
Messages
6,907,636
Members
3,157,829
Latest member
Fairfax44