phone no longer auto connects to vehicle now that it's paired with gear s3

Michael Paulsen

New member
Apr 7, 2017
2
0
0
Visit site
I was actually able to solve this very easily with tasker for anyone interested.

Well a combination of tasker and an app called secure settings actually.

My watch now remains connected for notification and audio connects to the truck automatically. Once I leave the vehicle everything returns to the watch.


*1. Open tasker and click the "TASKS" tab

*2. Click the + at the bottom right and give the task a name such as "Connect Car Audio"

*3. Click the + at the bottom right and select Plugin - Secure Settings

*4. Click the Pencil icon at the right of configuration and select Actions - BT Connection

*5. On the drop down select your vehicle

*6. Press the CONNECT/DISCONNECT button so it displays CONNECT

*7. Press the floppy disk icon to the right of BT Connection

*8. Click the < at the top left next to the tasker icon. You have now configured the task!



Now to create the profile (or the trigger that will run the tasks):


*1. Click the profiles tab

*2. Click the + at the bottom right and select state

*3. Select Net and the BT Near

*4. Click the magnifying glass on the right of Name and select your car bluetooth system. If you prefer you can select the address rather than name.

*5. Select the option "Standard devices"

*6. Click the < at the top left next to the tasker icon.

*7. You will now see a list of tasks to choose. Choose the connect car audio task (or whatever you named it).


In my screen shot below you will see that I created two profiles.. the second one is not necessary, it just gives me a notification that my phone HAS connected to my truck.. (Which also comes through to the watch) I mainly did this so I can monitor that this is working, but I may remove it at a later date. It seems to connect perfectly every time as it should so I really don't need to know about it.




//uploads.tapatalk-cdn.com/20170131/f7086d1f2bc7945fe900f8932a5d9299.jpg

//uploads.tapatalk-cdn.com/20170131/cb4b757a9adf11a1de6a10b1cd16d6e8.jpg


I'm all fairness I borrowed some of this tasker prowess from a post on redit but I removed a bunch of steps because they were simply not needed, and actually it works better my way. The original version has a prior task of telling tasker to disconnect from the watch and then power cycle bluetooth before connecting to the vehicle.. I have no idea why, but the end result of that is not being connected to the watch at all when in your vehicle (no notifications) and also having to setup exit tasks so it would reconnect to the watch on exit.. if that's what you prefer go for it, but my way the watch remains connected and you still get your notifications, only phone audio is routed to my truck which is exactly what I wanted.




So I seem to still be having an issue. This works to connect from my watch to my car, however, it does not re-connect to my watch once the car has been turned off. I don't suppose there is a fix you may have for this. If so, that'd be great.

Thank you!
 

Michael Paulsen

New member
Apr 7, 2017
2
0
0
Visit site
So I seem to still have an issue here. I did follow the directions, I believe, step by step. However, my issue occurs once I've turned the car off. When I get in, and power on, the car it switches to my phone, which is what I was hoping for, so that's a win. But, when I turn the car off it won't reconnect to my watch. Did I perhaps do something wrong or is there another fix to this?

Thank you!
 

Michael Davis4

New member
Dec 21, 2012
1
0
0
Visit site
So, this was a problem that I had read in an amazon review and it was a show stopper for me. I was NOT going to buy this watch if it messed up my phone operation in my truck. So, after reading your solution I'm going to purchase the watch. As far as you can see, this is a complete solution, correct?
 

Tyrane Lewis

New member
Feb 13, 2015
4
0
0
Visit site
I tried to be concise with the title but basically, just got the gear s3 a few days ago. Loving it so far. However I've noticed that now that my phone is constantly paired to my watch via Bluetooth, my phone no longer automatically connects to my truck when I get in. I can connect it manually and it does stay connected to the watch as well so I know the phone can do multiple Bluetooth connections but it no longer connects to the truck on its own. I assume because it's content to already be paired with something? Is this just something all smart watch users deal with or is it specific to the priv? Anybody come up with a good solution? I'd prefer to have both connect automatically but if I had to make a choice i'd prefer it drop the watch and pickup the truck when I'm driving..

I found solution to this problem. I have Moto Z Force that connected automatically to my Mini Paceman every time. but when i purchased the Gear S3 4G LTE, my phone and car wouldn't connect automatically because Gear S3 took priority for phone calls. What i did was pair the Gear S3 to the car and now the calls go to the car. when I don't have on the gear S3 the phone connects automatically. I hope this helps everyone with this issue.
 
Dec 10, 2015
7
0
0
Visit site
Thank you, just_luc! Your solution worked for me as well. I'm using the Gear S3 with a Pixel 2 XL. It does take a little time to connect but is much better than having to manually connect.
 

bdbplatano

Member
Jan 16, 2011
8
0
0
Visit site
Thank you, just_luc! Your solution worked for me as well. I'm using the Gear S3 with a Pixel 2 XL. It does take a little time to connect but is much better than having to manually connect.

I have a Pixel 2 XL as well but I am still having issues. I've turned off the "calling profile" in the Bluetooth setting for the watch. However, the Gear S3 is still blocking the phone from connecting to the car. As soon as I put the watch on airplane mode I can connect with the car, no issues. I can even turn the watch's Bluetooth back on immediately after the phone connects to the car and all three work without any problems.

Are you able to play music through Bluetooth?
 

WalkingHorse

Well-known member
Jan 18, 2011
249
0
16
Visit site
I have a Pixel 2 XL as well but I am still having issues. I've turned off the "calling profile" in the Bluetooth setting for the watch. However, the Gear S3 is still blocking the phone from connecting to the car. As soon as I put the watch on airplane mode I can connect with the car, no issues. I can even turn the watch's Bluetooth back on immediately after the phone connects to the car and all three work without any problems.

Are you able to play music through Bluetooth?

I'm having this exact issue. It used to work beautifully. I now have to turn my watch off before I start up my truck. Then my Note 8 will connect as normal for streaming and after connection I can turn my watch back on. Extremely frustrating.
 

WalkingHorse

Well-known member
Jan 18, 2011
249
0
16
Visit site
The last update fixed it for me. So happy as it was very frustrating having to turn off my watch before I started my truck, let the phone connect then turn my watch on.
 

yatta

New member
Dec 15, 2011
3
0
0
Visit site
I have a Moto x4 running 8.0 with security updates. I was having the same issue however I didn't want to use an app or anything. My car is also a 2013 Camry. I went into Bluetooth setting clicked on the Setting for the device and deselected phone and it appears to have worked. I still receive texts as well.
 

Attachments

  • Screenshot_20180725-181914.jpg
    Screenshot_20180725-181914.jpg
    92.7 KB · Views: 12

jubyjuby

New member
Nov 27, 2018
1
0
0
Visit site
Just bought the galaxy watch and was having this issue (bought a gear s3 last year and returned it because I couldn't solve this issue). 2013 Toyota Camry, Moto Z play. Followed the instructions and works perfect. Takes an extra 10-20 seconds to connect. Galaxy watch remained connected during the ride as well. Both functioned as they should. Thanks for the post! A surprisingly simple solution!
 

mikeng64

New member
Jul 8, 2019
1
0
0
Visit site
I had the same issue. My equipment: 2016 ZTE Axon7 (upgraded to Android 7, Bluetooth 4.0), 2018 Nissan Leaf and Samsung Galaxy Watch. I followed just_luc's instructions using Tasker, but I could not get Tasker to work properly for me. The task worked properly when I run it manually. But something was wrong with my Profile. It would not initiate the task when I got into my car. I know Tasker has many permissions that need to be set up properly, and I think I had them correct.

I upgraded my phone recently to the Google Pixel 3a. And, without setting up Tasker on the new phone, the phone Bluetooth-ed to my car properly while wearing the Samsung Galaxy Watch. So, my problem is now fixed, but it cost me $400 for the new phone. :)
 

Trending Posts

Forum statistics

Threads
945,882
Messages
6,927,485
Members
3,159,993
Latest member
ihatemakingaccounts350