Problem apps downloading by themselves making phone unusable


AC Question

Hi, this problem is driving me crazy ... I have a Utok D40 and the only games on it were Subway Surfer and Clash of Clans.
Then a whole host of "apps" started downloading onto the phone ... I tried and tried to uninstall them one by one but the just kept coming back and it was like they were running interference for each other, and most of them were very inapropriate.
I finally gave up as the phone had become so slow and most of the time not working at all.
I did a hard reset on the phone back to its "out of the box" state.
When I started it up I got the "Welcome" message, which was nice, but after about 10 minutes all the "apps" started coming back again.
The only apps that didn't come back were Subway Surfer and Clash of Clans.
I don't know what to do ... I keep getting regular "Unfortunately ............. is not working" messages which effectively stop me from doing anything.
I would appreciate any help ... :(