• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues please let us know in this thread!

Problems with my SGN3 running 5.0

Fulani Filot

Well-known member
Jul 11, 2015
I recently bought an SGN3 running Android 5.0 and not long after started having GPS-lock problems.

1. The GPS won't lock on to signals from detected satellites. I tried resetting using the *#0*# service menu as well as the app "GPS Status & Toolbox" but the problem persists. I also disabled a weather daemon I recently read of as a possible culprit but that hasn't helped.

2. I unrooted the phone (Kingoroot) but that hasn't fixed the problem.

3. I did a factory reset going it would go back to 4.4 or 4.3, this hasn't helped either; 5.0 is still onboard. Now it won't even root with Kingoroot.

4. I've tried updating the 5.0 from "Settings" and it's telling me they something we done to the phone that is preventing an update (see screenshots)

5. I've also downloaded two different 4.3 stock ROMs and tried getting each (in separate attempts) into the phone via flashing using Odin...that keeps failing (see screenshots).

I would really appreciate someone telling me what is going on with my SGN3/5.0 combo. For now I'm suspecting that the 5.0 is a problematic custom-stock-ROM (I've heard of warnings about them). I got the Odin (and user guide) from https://androidmtk.com/flash-samsung-stock-rom-using-odin

I've also included a screenshot of details of the 5.0 in my SGN3. Thanks in advance guys.


Trusted Member Team Leader
Dec 4, 2012
Samsung occasionally alters the bootloader so that you can't roll back to an earlier version of Android. This is probably why Odin fails to flash an older ROM.

You could try a different custom ROM if you can get a custom recovery on the device. What carrier do you have?