Project Fi WiFi Calling Bad

paradroid

Well-known member
Aug 26, 2010
634
6
18
Visit site
I moved to a new home in the exurbs. I am about 8 miles off a major highway and Project Fi pulls in a very weak T-Mobile signal - usually 3g, sometimes if the wind is right I get a weak LTE signal. So project fi switches me to wifi calling which is working terrible.

I am not sure why as I have checked my wifi speed on my phone and it is 50 Mbps + and very solid.

Before I call project fi support, is there anything I could check or do on my phone or wifi router to maybe improve wifi calling?

The strange thing, in my last home, wifi calling worked mostly fine with the occasional glitch, but now it is normally just bad.
 
Last edited:

o4liberty

Well-known member
Dec 9, 2009
2,955
95
48
Visit site
Have you tried resetting your device? I find a good reset is where I always start with any Android device. I just signed up for FI and hope it works as well as some say.
 

paradroid

Well-known member
Aug 26, 2010
634
6
18
Visit site
Have you tried resetting your device? I find a good reset is where I always start with any Android device. I just signed up for FI and hope it works as well as some say.

Factory reset. Not yet, I really don't want to spend the time fiddling with phone to get things like I want them again. Moving to a new home after being in the last one for 20 years and getting everything set up is taking all my time at the moment.

Any settings to check on my phone?
 

TraderGary

Trusted Member
Apr 12, 2012
3,056
54
48
Visit site
What is your router speed? I never have any problem with WiFi calling as I have a solid, reliable connection. I've been on Fi since last September and I love it.
 

paradroid

Well-known member
Aug 26, 2010
634
6
18
Visit site
I get constant 280 mbps wired. I get up to 50 to 150 mbps wireless depending on where in the house.

Are there any setting to check on the phone?
 

TraderGary

Trusted Member
Apr 12, 2012
3,056
54
48
Visit site
Your WiFi speed should be more than adequate to support reliable WiFi calling. I live in a low area and there is no cell phone signal in my house. I depend entirely on WiFi calling. My router is a NetGear Nighthawk R8000. I'm on Comcast in a rural area about 25 miles from Atlanta, GA. My Router speed is consistently 180 Mbps. My WiFi calling is 100% reliable.

Based on my experience, I would contact Google Fi. Something is certainly not working correctly.
 

tpero

Active member
Dec 16, 2015
42
0
0
Visit site
Are you using an ISP-provided modem/router or your own? I used to have a Comcast/Xfinity modem/router in bridge mode going to my Google WiFi mesh network, and the internet connection would drop intermittently all the time. I finally ordered my own modem and returned the Comcast one, and it's been MUCH more reliable since, almost flawless. A tech at Comcast explained to me that they constantly push updates to their modems that often end up interrupting the signal or breaking certain functionality.
 

TraderGary

Trusted Member
Apr 12, 2012
3,056
54
48
Visit site
You bring up a good point, tpero. In addition to my own NetGear R8000 router I also use my own NetGear CM1000 Cable Modem. I learned long ago that Comcast was billing me an extra $10 per month to "rent" their cable modem. Over the past 20 years I've supplied my own cable modem, eliminating that rental fee. Over the past 20 years Comcast would have charged me $2,400 in cable modem rental fees. Supplying my own much superior cable modem eliminated that $10 per month rental charge. On Amazon the NetGear CM1000 Cable Modem is $159.
 

paradroid

Well-known member
Aug 26, 2010
634
6
18
Visit site
I have my own stuff. I have a very good and expensive Buffalo wifi router with DD-WRT pre-installed and a brand new 1 gigabit capable netgear cable modem.

All internet works perfectly and super fast with no drop outs.

I just checked the box for the QoS setting in my adapter settings and see if that will help. May need log into my router and see if there are any settings in DD-WRT that I can change.
 

Almeuit

Moderator Team Leader
Moderator
Apr 17, 2012
32,278
22
0
Visit site
Personally I hate WiFi calling .. Simply due to if I am paying a wireless carrier then have to rely on my home internet well .. That is a problem. Why pay the wireless carrier?

I digress. I haven't had to use WiFi calling but I know Verizon forces mobile versus WiFi. I know others should allow an option so ensure to check it prefers WiFi versus cellular to just to be sure.
 

paradroid

Well-known member
Aug 26, 2010
634
6
18
Visit site
Personally I hate WiFi calling .. Simply due to if I am paying a wireless carrier then have to rely on my home internet well .. That is a problem. Why pay the wireless carrier?

I digress. I haven't had to use WiFi calling but I know Verizon forces mobile versus WiFi. I know others should allow an option so ensure to check it prefers WiFi versus cellular to just to be sure.

If you live out of range of a tower, wifi calling would be great if it worked well, I disabled and reenabled my ethernet adapter on my computer and also turned on QoS packet scheduler and it seems wifi calling is a bit better but have not done many calls to really test.
 

Almeuit

Moderator Team Leader
Moderator
Apr 17, 2012
32,278
22
0
Visit site
Oh I mean I get why it exists but I definitely prefer cellular so it isn't relying on me having power or internet.
If you live out of range of a tower, wifi calling would be great if it worked well, I disabled and reenabled my ethernet adapter on my computer and also turned on QoS packet scheduler and it seems wifi calling is a bit better but have not done many calls to really test.
 

L0gic23

New member
Nov 2, 2018
1
0
0
Visit site
You may need to call project fi support and request they:

1: enable wifi calling in their backend system
2: prefer wifi calling in their backed system
3: prefer wifi data in their backend system

3 is optional unless you prefer to pay for cell data while your phone is connected to your WiFi.

Yes you really need to do this... I know it seems stupid but after much research and talking to multiple reps I learned of these 3 backend settings which supersede your phones settings...

Also, I had no luck getting this done via email, I had to call, several times, to get all 3 of these settings changed. I also recommend calling again to verify it all 3 changes were made successfully as my first success only enabled 2 out if 3... That's right, they preferred wifi calling but did not enable wifi calling, leaving me with a very inconsistent wifi calling experience.
 
Last edited:

Trending Posts

Forum statistics

Threads
941,436
Messages
6,908,829
Members
3,157,927
Latest member
zigzagchamber