Random Restarts

hamc17

New member
Nov 28, 2014
3
0
0
Visit site
Hi guys,

My S4 recently started to restart on its own and generally become useless which I presumed was due to a faulty battery, as it barely held charge for a few hours on standy.

I replaced my battery which now last the whole day with regular use, but I'm suffering random restarts for no particular reason. The restarts can happen while just in standy, making a call, an alarm going off, playing music, etc so I'm not sure its down to a specific app or anything.

I upgraded to 4.4.2 but that had no effect other than a few visual changes.

I have wiped the cache, factory restored, restored to a backup etc but I still suffer the restarts. When the phone restarts it will display 2 clocks on the lock screen rather than one, and briefly an R over the network bars indicating that it think I am roaming. I could dump the logcat files, but I'm not sure what message to look for indicating when the phone restart and what caused it.

Has anyone else suffered random restarts like this? If there's no fix I may just wait for Lollipop to drop and do another restore once it arrives.

Thanks.
 

tklemp

Member
Nov 28, 2014
7
0
0
Visit site
I'm having a similar issue. I charged my phone to 100% and by the time it gets to 75-80% it shuts off and can not be powered on until I plug the power cord back in. I'm thinking it's the battery and currently waiting for some extra batteries to arrive. However, I'm not entirely sold that it is the battery. Any thoughts?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,955
5,270
113
Visit site
Do you know anyone who also has an S4? Ask them if you can swap batteries for a day to see how things work.
 

hamc17

New member
Nov 28, 2014
3
0
0
Visit site
Are you rooted?

I am rooted, yes. The restarts started before I rerooted however.

Welcome to Android Central! Try booting into Safe Mode. If the problem doesn't recur, then it's likely that some app you've installed is causing the instability. The challenge with random restarts is trying to pinpoint which app. *Edited out link as I can't post links*

I'll give this a try and report back.

I'm having a similar issue. I charged my phone to 100% and by the time it gets to 75-80% it shuts off and can not be powered on until I plug the power cord back in. I'm thinking it's the battery and currently waiting for some extra batteries to arrive. However, I'm not entirely sold that it is the battery. Any thoughts?

My previous battery did something similar. At 75% it'd shut down and wouldn't restart unless I plugged it in. Pretty sure it's the battery!
 

beagle82

Well-known member
Aug 2, 2013
387
0
16
Visit site
I am rooted, yes. The restarts started before I rerooted however.



I'll give this a try and report back.



My previous battery did something similar. At 75% it'd shut down and wouldn't restart unless I plugged it in. Pretty sure it's the battery!
First thing would be to check the battery. Place it on a flat surface and check for any bulging. If there is any bulging, then you probably found the culprit.

Next, install xposed framework (if you don't have it already) and install the "samsung kitkat systemserver crash fix" module. This worked for my wife's S4. Not a single random reboot since.
 

hamc17

New member
Nov 28, 2014
3
0
0
Visit site
First thing would be to check the battery. Place it on a flat surface and check for any bulging. If there is any bulging, then you probably found the culprit.

Next, install xposed framework (if you don't have it already) and install the "samsung kitkat systemserver crash fix" module. This worked for my wife's S4. Not a single random reboot since.

Fantastic, that module worked! The crash report showed that a knox process was in state -1, so that's a little odd as I've disabled knox. But it worked! Thank you!
 

beagle82

Well-known member
Aug 2, 2013
387
0
16
Visit site
Fantastic, that module worked! The crash report showed that a knox process was in state -1, so that's a little odd as I've disabled knox. But it worked! Thank you!

No Problem. Glad it did the trick. I was going to say uninstall everything related to knox as thats what i did with the wifes phone, but since you said it had been happening before you rooted, i was uncertain whether it could have been the culprit. But nevertheless its working.
 

Trending Posts

Forum statistics

Threads
944,504
Messages
6,923,089
Members
3,159,588
Latest member
Felichino