Repopulating media after clearing "Media Storage"

extremeragnarok

New member
Feb 18, 2016
2
0
0
Visit site
Yesterday, there was 1 picture I was trying to attach to a group text. Just 1. I couldn't get it to show up in the gallery, despite moving it around to different directories, so I found myself in these forums looking for a solution. People suggested clearing the data and cache for the Media Storage. Not only did that not work, entire albums disappeared from my gallery. The icing on the cake is all the ringtones and notifications got reset. Nothing I do can get the lists to repopulate. Now Zedge can't even change ringtones or notifications.
Is there a way to fix this?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,713
4,872
113
Visit site
Welcome to Android Central! What file format is the photo--jpg or png, or something else? What directories have you tried moving it to? Using My Files, make sure there isn't a file called ".nomedia" in any of the directories that the photo is in, as well as any parent directory. ".nomedia" instructs the system to ignore that directory and any subdirectory when scanning for media files to add to the various databases. Also, were you moving the photo only to directories on Internal Storage or the microSD card?

Try using media.Re.Scan to force the system to rescan.

Also, use My Files to look for those albums that disappeared--the actual photo files are most likely still in your phone's storage, but just got lost from the Gallery's database.