S4 charging but no lightning sign/USB not detected

Syafiq Huzir

New member
May 7, 2013
Visit site
Hello. I have been using s4 since its released and have it rooted. It has been fantastic so far until last week.

Out of the blue, my s4 wont detect the cable put into it. Usually when you put a cable into it there will be a lightning sign on the battery icon and also "phone is charging" written in the middle of the screen.
But now nothing happened. However if I just left the phone, it will be charged until 100%.

Same thing happened with the USB. My PC has been detecting the s4 all the time before. But now when I put in the USB cable. Nothing happened.

Weird enough, when I tried to put on the USB in the OdinMode, it can be detected. So i thought it must be a firmware issue not a hardware issue. I have tried unroot my s4 and reset to factory setting.
But that doesnt solve the problem. Anyone has experienced this or have any suggestion?

Thank you


New member
Aug 21, 2013
Visit site
I have the same problem - as do zillions of others if one reads the numerous internet postings on this topic. I did not root my phone either.

Samsung's quality control is going from bad to worse.

I have returned my phone to the vendor for a refund, which they have agreed to pay. They are required to do so under EU law which effectively gives the consumer a two year statutory warranty. The vendor also has to pay my out of pocket costs due to the breach of contract - ie failure to supply a phone free of defects.

I tried to contact Samsung regarding the issue, but found their website appallingly difficult in terms of accessing a human being that works with Samsung at the other end.

Samsung seem focused on coming up with "whiz bang" product "innovations", many of which don't work properly. The aim seems to me to be to grab as many col cms of media coverage, and make cute TV advertising. At the expense of producing a quality phone. The sooner people wake up to this, and stop buying Samsung, the better. I also have an S3 and the audio output failed. Another return to the vendor. (Other than that the phone was fine).


Trending Posts

Forum statistics

Latest member