S6 Won't charge, but turns on/can idle in recovery screen with charger in etc.


AC Question

Hi! My S6 is being strange. It suddenly won't charge, I didn't recently drop it or installed any new apps.

When I plug in while the phone is off, it flashes the charge icon for a few seconds, but doesn't charge or do anything. I can also idle in the recovery menu and it won't turn off there, despite the charge being 0%. I'm unsure if it's like this by default, or just in my circumstances, but it's staying on forever in this menu.

My pc also won't detect it, I tried a new cable and it also doesn't work. I've tried different wall outlets and by pc but nothing will charge it. It still boots at 0% and I can navigate around quickly but I can't get anything done.

I'm not sure what to do, but I assume the charge port is messed up. I'm not sure why it would be, though. I assumed it was the cable because it has a tiny tear in it at the base of the end towards the phone plug. It could be the port but I'm hoping it isn't.

How come it shows the icon when plugging in? But doesn't do anything else?

Would greatly appreciate the help! :)