Samsung S7FE Tab does not recognize USB connection to digital piano since recently; A14 , OneIU 6.0

TSFDeymos

New member
Apr 27, 2024
2
1
1
Visit site
Hello everyone,
I hope you can help me, I'm really frustrated by now. Thanks for the answers.

Android version 14, One UI 6.0

My problem:
I have a Samsung S7FE tablet, which I use for learning and practicing on the piano (Kawai ES920). This has always worked without any problems.
Recently (although I have not updated, at least not that I am aware of) the tablet does not recognize when I connect it to the piano via USB. No notification that a USB device has been connected and the apps also report that there is no connection.

The strange thing is that I have a Samsung cell phone (S22) with the same software versions, where the connection works immediately. So we can rule out the cable and the USB port on the piano. When I connect the tablet to the PC, it is also recognized immediately, so we can also rule out a defective USB port on the tablet.

I have checked that all the settings between the two devices (i.e. cell phone and tablet) are absolutely identical. This is the case, so it shouldn't be a problem.

I have already tried the following steps on the tablet, without success:

- Reset all settings
- Reset to factory settings
- Reset and copy all data from the cell phone via SmartLink
- Empty USB app cache/data
- Developer mode (also active on the cell phone)

- Tried all USB developer options, like 3GPP AT on and off, change USB default configuration, USB audio routing on/off

I'm really running out of ideas. As I said, from one day to the next no connection, but with the cell phone it works perfectly.
If you need any more information or screenshots, please let me know.

Thanks and best regards,

Deymos
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,957
5,271
113
Visit site
Welcome to Android Central! Your reasoning that it can't be the USB cable or port is sound, but at this point, it's still worth trying a different cable, and also making sure the tablet's USB port is completely clean (by scrubbing it with a toothbrush dipped in rubbing alcohol).

Also, check to make sure the tablet's completely up to date in terms of monthly security updates as well as Google Play System Updates (you can find both options in Settings>Security & Privacy>Updates).
 

TSFDeymos

New member
Apr 27, 2024
2
1
1
Visit site
Hi B. Diddy,

just wanted to let you know that I bought a new cable and in fact, it kinda works. Although I have no idea why, but with the new cable the connection worked instantly.

Strangely, after that, the connection works with the old cable again as well. I have no clue why that is.

After some testing, I found out that there is still a connection issue with both cables, that was not before.
After I restart the App or unplug and replug the cable, the connection wont work again, until I restart the pad.

I mean, I can work with that, just have to restart the pad when I am going to train piano. It is just a bit tedious and I still have no idea what was changed.

But thanks nonetheless (y)
 
  • Like
Reactions: Laura Knotek

Trending Posts

Forum statistics

Threads
944,506
Messages
6,923,105
Members
3,159,591
Latest member
cooongame789