Samsung Tab 2 stuck in recovery mode loop

  • Thread starter Android Central Question
  • Start date

Android Central Question

Hi, I have an ageing Samsung Tab 2 which, although running a bit slow, as you would expect for its age, was working fine until the other night. I plugged it in to charge overnight and it was charging OK. By the morning it is in recovery mode and I cant past it. Here is what happens and what I have tried:

1. Reboot - The Samsung Tab 10.1 screen flashes up but not the Samsung blue flashing logo. I then get and android on its back and No Command message and recovery mode is launched

2. Tried factory reset - looked like it worked but when it rebooted back to 1. above

3. Tried to clear cache partition - came up with error message, rebooted itself and back to 1. above.

It seems is is failing at the very start of the boot up process and I dont know why. My only thought is that it was trying to update something overnight on the OS and has failed spectacularly.

Can anyone offer any other things that I could try please or is it a terminal problem?


Retired Moderator
Feb 12, 2012
Visit site
See if you can get it into download mode (From off, Volume Down and Power at the same time until you see the Warning! screen. If you can't, the tab is hard-bricked and probably doesn't pay to get working. (The cheapest way is probably to find someone on eBay who can JTAG a Tab 2.)

If you can, see [Samsung] How to flash Stock ROM via ODIN. (Ignore the part about getting into download mode, you're already there.) Find the ROM image and flash it. (The guide has pictures and everything. :) )

Android is gone from the tablet, so is anything you may have had on it, so you don't have to worry that flashing a ROM wipes all your data - it's already wiped.