Script to Delete Battery Stats

therent

Active member
Oct 12, 2010
42
1
0
Visit site
Charged up to 100 percent.

Installed via red cwm, ran it in terminal emulator. quick and painless.

Now to drain the life outta this thing.
 

Billvert

Member
Dec 1, 2010
15
0
0
Visit site
I haven't been able to wipe in blue, Green or RED CWM I get the same error message.
E:can't mount /dev/block0p1

After 3 full drain/Charge cycles in a row Using Tuneinradio full volume, GPS, WIFI and the screen flash light to drain the Battery my battery seems to function on DL30 as it did on Dl09 now.

I will give this script a try anyway though because I have noticed the "unplug charger" warning seems to cycle a tad faster when I leave it plugged in at night. This may indicate that the battery IS draining a little faster or there's a voltage reading error.
 
Last edited:

clifto

Member
Dec 10, 2010
14
1
0
Visit site
This is not a complaint. In fact i love doing all this mod/flashing.

When i installed the .zip in odin then rebooted i got the nasty FC errors none stop.

Im running 2.4 SC voodoo. I had the am/pm removal mod and ran Chris3D's batt mod script to get his cool batt charger icons to work on 2.4. Those two thing were done prier to trying your .zip.

Just wondering if anyone else has had the issue.
 

clifto

Member
Dec 10, 2010
14
1
0
Visit site
Well I did a fresh install of 2.4 SC-V tried the battstatwipe zip and it worked great this time. I then installed the no am/pm mod, after that ran Chris3D's batt mod script and everything is running smooth this go around. :)
 

Billvert

Member
Dec 1, 2010
15
0
0
Visit site
I downloaded the file bstats. zip to the root of the sd card.

I used Red (CWM voodoo Lagfix Recovery v.2.5.1.x update > choose zip file option. It said bstat.zip was loaded successfully to phone.

I rebooted with CWM and opened Connectbot, entered command SU to get root prompt typed bstat, and got "file not found" I looked in root (/) and file was not there.
I went back into CWM red and still got the error:
E:can't mount /dev/block0p1
then tried cd / then "ls"
the file bstat.zip does not show file in root directory of phone" It is not in cd /system. either. I am confused.
I guess I will try the "mv" command to move the file "bstat.zip" to the phone.

Question does the file belong in the root (/) of the phone?
Question 2 Can you use the mv command in android or do I have to use the rename command.
I do have root explorer but I am trying to re-learn command line from my Linux days.
 

Kevin Gossett

Retired Moderator
Sep 9, 2010
1,634
281
0
Visit site
I downloaded the file bstats. zip to the root of the sd card.

I used Red (CWM voodoo Lagfix Recovery v.2.5.1.x update > choose zip file option. It said bstat.zip was loaded successfully to phone.

I rebooted with CWM and opened Connectbot, entered command SU to get root prompt typed bstat, and got "file not found" I looked in root (/) and file was not there.
I went back into CWM red and still got the error:
E:can't mount /dev/block0p1
then tried cd / then "ls"
the file bstat.zip does not show file in root directory of phone" It is not in cd /system. either. I am confused.
I guess I will try the "mv" command to move the file "bstat.zip" to the phone.

Question does the file belong in the root (/) of the phone?
Question 2 Can you use the mv command in android or do I have to use the rename command.
I do have root explorer but I am trying to re-learn command line from my Linux days.

Running this zip simply clears the battery stats. It won't load an app or anything like that
 

Billvert

Member
Dec 1, 2010
15
0
0
Visit site
Running this zip simply clears the battery stats. It won't load an app or anything like that
Thanks Kevin, as much as I like Flashing, theming, romming and playing with my new toy this was beginning to not be fun anymore. Thanks again for the help, I will cycle the battery a couple of times now and see how it works.
 

JeremytheIndian

Well-known member
Oct 5, 2010
361
37
0
Visit site
Adrynalyne saves the day.... again! :)

With these smart batteries is it really necessary to drain down to 5% before doing a full recharge and wiping or vice versa?
 

djlim4

Well-known member
Jan 2, 2011
100
20
0
Visit site
Question. So is CW definitely not clearing batt stats? or is this for people getting some kind of error? I know when I clear batt stats in clockwork, it's pretty quick but not instant as if it cleared nothing... i guess it doesn't hurt to use this later. Just curious.
 

tnez21

Well-known member
Sep 27, 2010
286
35
0
Visit site
Running this zip simply clears the battery stats. It won't load an app or anything like that

Is that right? OP says to install in CW and that THEN you can run it CW or Terminal.

For Terminal (I used android terminal emulator from the market)
1. after installing bstats.zip in CW boot phone back up
2. open terminal emulator, press menu button, then preferences
3. scroll down to "shell" and changed initial command to read
"export PATH=/system/xbin: $PATH
4. press back button, Terminal will close, reopen terminal
5. type "su" hit return, grant su when promt pops up
6. type "bstats" and hit return
7. phone will reboot.

I dont know if any of the above is correct but both worked for me.
 
Last edited:

tnez21

Well-known member
Sep 27, 2010
286
35
0
Visit site
Question. So is CW definitely not clearing batt stats? or is this for people getting some kind of error? I know when I clear batt stats in clockwork, it's pretty quick but not instant as if it cleared nothing... i guess it doesn't hurt to use this later. Just curious.

it was doing the same for me but something was telling me that it wasnt wiping because whenever i charged to 100% as soon as would unplug from the charger my batt would drop to 97/96%. this happened no matter how many times I wiped batt stats in CW. after running this script I unplugged from charger and batt stats stayed at 100%....so I'm guessing it works.
 

Billvert

Member
Dec 1, 2010
15
0
0
Visit site
Question. So is CW definitely not clearing batt stats? or is this for people getting some kind of error? I know when I clear batt stats in clockwork, it's pretty quick but not instant as if it cleared nothing... i guess it doesn't hurt to use this later. Just curious.
I am one of those getting the error in CWM red. When I wipe battery stats I get this error:
E:can't mount /dev/block0p1
I loaded adrynalyne's script and used the terminal method. Now my phone reboots after giving the bstats command so I guess its working.
 

djlim4

Well-known member
Jan 2, 2011
100
20
0
Visit site
it was doing the same for me but something was telling me that it wasnt wiping because whenever i charged to 100% as soon as would unplug from the charger my batt would drop to 97/96%. this happened no matter how many times I wiped batt stats in CW. after running this script I unplugged from charger and batt stats stayed at 100%....so I'm guessing it works.

Ok, so you definitely had some issue with your battery stats it sounds like. I'm gonna try it later when I get home to see if there's any difference, but my battery life seemed to be alright ever since EB01... DL30 i could barely get it to last the day. I've been on low to moderate use today since 9AM and my battery's sitting at 58%, so i'd say this is pretty good... someone correct me if this sounds really off.
 

Forum statistics

Threads
943,839
Messages
6,920,270
Members
3,159,254
Latest member
roth4796