• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues please let us know in this thread!

Server and Certificate errors in public wifi


New member
Aug 31, 2018
I'm so frustrated. I often stop at McDonalds for coffee. And I like to use their public wifi, which in my case appears to be attwifi.

When I'm trying to use the internet I keep getting two errors. The first appears to be from the hotmail mail account I have installed on my phone. The error keeps telling me the certificate is not secure. See attachment one. I've tried researching and am told there is a way to tell my phone to accept ALL certificates, which is fine with me. But I can't find any such option.

Then, when I try to visit websites, many many times I get an error screen telling me my connection is not private. I can not get around that screen. It acts like a brick wall, denying me access. In case it was just Chrome at fault, I tried the Samsung web browser, same thing. See attachment 2.

Can someone help me with a clear step by step on how to get rid of one or both of these error?

I appreciate your time.


  • McD error 1.jpg
    McD error 1.jpg
    178.6 KB · Views: 9
  • McD error 2.jpg
    McD error 2.jpg
    104.3 KB · Views: 8

Ask The Community

Trending Posts

Forum statistics

Latest member