SGS3 Powering Issue

Perfect_Marx

Member
Oct 8, 2012
9
0
0
Visit site
So I dropped my phone in the water a few days ago, perhaps for a second, so I promptly removed it and put it in rice, along with a nice dose of the hair dryer. After a few days, everything seems to work fine again, except for one odd issue; when my phone is unplugged and the battery is out, when i put a charged battery in, the phone won't boot when I press the power button; even if I don't press the power button, it will just vibrate every couple of seconds and not turn on. What should I do, and what is my issue?
 

Golfdriver97

Trusted Member Team Leader
Moderator
Dec 4, 2012
35,367
113
63
Visit site
So I dropped my phone in the water a few days ago, perhaps for a second, so I promptly removed it and put it in rice, along with a nice dose of the hair dryer. After a few days, everything seems to work fine again, except for one odd issue; when my phone is unplugged and the battery is out, when i put a charged battery in, the phone won't boot when I press the power button; even if I don't press the power button, it will just vibrate every couple of seconds and not turn on. What should I do, and what is my issue?

How long has it been since you dropped it in water?
 

GSDer

Well-known member
Jan 30, 2011
8,471
15
0
Visit site
Am I to assume that if the phone is plugged in (with or without a charged battery) then it boots normally? And once it boots normally (with a charged battery in place) you can unplug it and everything is ok? Or is there something missing from your description?
If it boots normally then my suggestion would be useless.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
 

Perfect_Marx

Member
Oct 8, 2012
9
0
0
Visit site
Am I to assume that if the phone is plugged in (with or without a charged battery) then it boots normally? And once it boots normally (with a charged battery in place) you can unplug it and everything is ok? Or is there something missing from your description?
If it boots normally then my suggestion would be useless.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2

Yeah, when plugged in with a battery in the phone, it boots just fine and charges just fine. When I unplug it after I've powered it on, it also works just fine. It just won't boot when the phone is off and the battery is charged and in the phone, but the phone itself is unplugged.
 
Last edited:

GSDer

Well-known member
Jan 30, 2011
8,471
15
0
Visit site
^ What he said...

At least it's mostly functional. If you have insurance you could pay the deductible and get a replacement; I think it'll be a bigger $$$ hit to get it repaired through Samsung, along with all that time without a phone.
It's probably in good enough shape that, with some care, you could make it to your next upgrade.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
 

Perfect_Marx

Member
Oct 8, 2012
9
0
0
Visit site
^ What he said...

At least it's mostly functional. If you have insurance you could pay the deductible and get a replacement; I think it'll be a bigger $$$ hit to get it repaired through Samsung, along with all that time without a phone.
It's probably in good enough shape that, with some care, you could make it to your next upgrade.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2

Huh. Well, it seems to work now, but only after I wait 30 minutes or so after pulling the battery to put it back in. Weird.

Thanks for the help anyways, much appreciated. I think I'll wait for that Note 4 next year for my next upgrade, haha.
 

Golfdriver97

Trusted Member Team Leader
Moderator
Dec 4, 2012
35,367
113
63
Visit site
Huh. Well, it seems to work now, but only after I wait 30 minutes or so after pulling the battery to put it back in. Weird.

Thanks for the help anyways, much appreciated. I think I'll wait for that Note 4 next year for my next upgrade, haha.

Thanks for the follow up.

Sent from a SlimROM S3.