SMS not going through without turning off WiFi

legbuh

Member
Feb 1, 2014
7
0
0
Visit site
My wife and I both have Pixel phones running stock ROMs.

We've noticed when our AT&T signal is weak (2 bars or so) SMS messages will not always go through. In fact, rarely do they unless we're on the top floor of our house (better AT&T signal up there for sure).

On the main floor they may go through 1 out of 10 times. But, if we see it's hanging and not sending if we turn of Wifi they immediately go through.

We've had calls go right to voicemail as well.

I don't understand how turning off WiFi would help SMS messages go through. Are the signals clashing? Never had this problem before on Samsung Galaxys or my last phone which was a google nexus 5x.
 

lerdsuwa

Member
Jan 17, 2017
14
0
0
Visit site
Maybe the phone is trying to send SMS via Wi-Fi Calling and fails. When you turn off Wi-Fi, the SMS is sent in the traditional way via the phone network.
 

legbuh

Member
Feb 1, 2014
7
0
0
Visit site
WiFi calling doesn't appear to be an option on my Pixel.

Not sure if it's because AT&T or not.

It also doesn't happen all the time. But it seems like all the time since it happens later in the afternoon/night when we both want to send messages.
 

racedog

Well-known member
Feb 3, 2011
1,250
198
63
Visit site
My understanding is that AT&T does not allow wifi calling from the Pixel. You might want to verify that with them.
 

legbuh

Member
Feb 1, 2014
7
0
0
Visit site
That's what I understand as well, and probably the reason that the option doesn't exist.

Could it be that it's on by default in the background and since it doesn't work it's causing issues when I have a weaker AT&T signal?

Either way, it is very annoying and I'm open to suggestions.
 

d4787

Active member
Jul 25, 2014
34
0
0
Visit site
I have a similar issue. MMS often do not send when at home. My wifi signal is strong and network coverage is good. I usually have to go to airplane mode for a second then of and once this a are established it sends. Project Fi.
 

rcrc001

Member
Dec 21, 2016
23
0
0
Visit site
Check Available Storage; you want at least 15% of available storage. Also, check Network Mode try switching out of Global and try LTE.
 

legbuh

Member
Feb 1, 2014
7
0
0
Visit site
Just an update on the issue. When I turn off WiFi I see in the cellular signal bar a small x in the bottom right for a second or so when wifi is turned off, then that goes away and SMS goes right through.

Very annoying.
 

legbuh

Member
Feb 1, 2014
7
0
0
Visit site
Nope. I don't know why rebooting a router would affect SMS when AT&T doesn't use Wifi. The problem is, I believe, that the pixel phone assumes it can so it tries to and fails. when I turn of wifi things work as they should.

I am trying different SMS programs now to see if it's the phone or the Hangouts app that is doing it.
 

muzzy996

Well-known member
Feb 3, 2011
1,087
0
0
Visit site
I have no issues on AT&T with texting whether on WiFi of not other than the known issue with receiving MMS from Samsung phones that have advanced messaging enabled (which is not your issue, just full disclosure on my part). SMS should definitely work for you, what version and build are you on and when did you get your devices? I ask because I am a few months back (December update). Is the issue the same regardless of what WiFi network you are on?
 

Forum statistics

Threads
944,566
Messages
6,923,387
Members
3,159,625
Latest member
Bendytoy